Lack of Proper SQL Indexes Causes Slow Software Inventory Processing (268795)
The information in this article applies to:
- Microsoft Systems Management Server 2.0 SP2
This article was previously published under Q268795 SYMPTOMS
After you install Systems Management Server (SMS) 2.0 Service Pack 2 (SP2) on a primary site, the Software Inventory Processor component may experience poor performance when it processes software inventory data.
This poor performance is usually noticeable by observing a backlog of .sic and .sid files in the \SMS\Inboxes\Sinv.box folder.
Also, custom queries that you create in the SMS Administrator console that use software inventory data may take a long time to be processed.
CAUSE
This problem is caused by a combination of events. If you installed the hotfix described in Microsoft Knowledge Base article Q238762 while the site server was running SMS 2.0 Service Pack 1 (SP1), this could result in a large number of records in the SoftwareFile and SoftwareProduct tables in the SMS site server's database.
For additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
238762 Software Inventory Creation Date Is Incorrect in SMS Database
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUND
The SMS 2.0 SP2 Release Notes specifically state that the software inventory tables should be truncated before you apply the service pack. Because installing the service pack forces all clients to generate a complete software inventory record, this action does not have an adverse effect on the processing that is performed on the site server.
You can truncate the necessary tables by using the following SQL query:
TRUNCATE TABLE SoftwareInventoryStatus
TRUNCATE TABLE SoftwareInventory
TRUNCATE TABLE SoftwareFile
TRUNCATE TABLE SoftwareProduct
If you perform this action a long time after you install SP2, it will result in Software Inventory resynchronization commands being generated at the site server for each SMS client. The site will recover in time, but it may take some time before the clients receive the resynchronization commands and then generate complete inventory records.
If you use this method to correct the problem, it may not be necessary to install the hotfix because the hotfix will provide only marginal performance increases if the software inventory tables remain small. However, the more file types (for example, .dll, .exe, .vxd, files, etc.) that are returned by software inventory, the larger the tables will become. Installing the hotfix should also speed performance of custom queries that query the software inventory data.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 3.
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
---|
Keywords: | kbQFE KBHotfixServer kbBug kbDatabase kbfix kbInventory kbsms200fix kbsms200preSP3fix KB268795 |
---|
|