XFOR: Messages Stuck in Outbound Waiting Delivery Queue in Internet Mail Service (268494)
The information in this article applies to:
- Microsoft Exchange Server 5.0 SP1
This article was previously published under Q268494 SYMPTOMS
When you are running two Exchange Server 5.0 Service Pack 1 (SP1) computers on the same subnet in the same Exchange site, you may experience a problem if you have the Internet Mail Service installed on both servers.
If both servers are connected to an Internet service provider over a T1 line, and Server A is designated for inbound and outbound messages while Server B is set for outbound messages only, Internet messages may stop in the outbound waiting delivery queue in the Internet Mail Service (IMS) on Server B.
CAUSE
This behavior can occur when the routing table for the site has not been updated.
RESOLUTION
To resolve this behavior, update the routing table in the MTA on the server set for outbound messages (Server B):
- In Control Panel, double-click Services, and then stop the Internet Mail Service.
- Start the Exchange Administrator program, expand the Configuration container, expand the Servers container, and then click Server B.
- Open the Message Transfer Agent properties page, click the General tab, and then click Recalculate Routing.
- Back up the Imcdata\Out directory, which is located in <DRIVE>:\Exchsrvr\Imcdata. Then delete all files in the Imcdata\Out directory.
- In <DRIVE>:Exchsrvr\Imcdata\, delete the Queue.dat file.
- In Control Panel, double-click Services, and then start the Internet Mail Service.
- Send a test message to make sure that the message is delivered.
- To recover messages, repeat Steps 3 through 5.
Modification Type: | Minor | Last Reviewed: | 4/21/2005 |
---|
Keywords: | kbprb KB268494 |
---|
|