Terminal Services event messages 1100 or 1114 in Windows 2000 Server or Windows Server 2003 (268065)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

This article was previously published under Q268065
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

An event ID 1100 message is logged in the Event Viewer on a Microsoft Windows 2000 Server-based computer, or an event ID 1114 message is logged in the Event Viewer on a Microsoft Windows Server 2003-based computer. The event ID messages may be similar to the following messages: Event Type: Error
Event Source: TermServDevices
Event Category: None
Event ID: 1100
Description: Initialization of Notify Failed.

Event Type: Error
Event Source: TermServDevices
Event Category: None
Event ID: 1114
Description: Error communicating with the Spooler system service. Open the Services snap-in and confirm that the Print Spooler service is running.

CAUSE

This behavior occurs because the spooler service on the server has stopped.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, try the following methods until the issue is resolved:
  • Start the spooler service on the server.
  • Turn off Windows printer mapping and LPT port mapping for Terminal Services connections. To do this, follow these steps:
    1. Click Start, click Run, type TSCC.MSC, and then click OK.
    2. Click Connections, and then double-click RDP-Tcp.
    3. Click the Client Settings tab.
    4. Click to clear the Windows printer mapping check box, click to clear the LPT port mapping check box, and then click OK.
  • As a last resort, you can add the fEnablePrintRDR registry entry to delete the error message. To do this, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd

    3. On the Edit menu, point to New, and then click DWORD value.
    4. Type fEnablePrintRDR, and then press ENTER.
    5. Double-click fEnablePrintRDR, in the Value data box, type 0, and then click OK.

      Note Setting fEnablePrintRDR to 0 (disabled) will also disable client drive mappings.

Modification Type:MinorLast Reviewed:1/20/2006
Keywords:kberrmsg kbprb KB268065 kbAudITPRO