XCCC: "Access Is Denied" Error Message When Accessing Folders in Outlook Web Access (267569)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q267569 SYMPTOMS
When you click the Folders button and try to access public folders in Outlook Web Access (OWA), you may receive the following error message:
Access is denied. Your browser security settings will not allow access to this folder from this page.
You may also receive the following error after you click Folders in the OWA interface:
Permission Denied 70
NOTE: that after you click OK on the above error, the folder list is presented without the Public Folders.
CAUSE
You are using the fully qualified domain name (FQDN) in the URL. An example of a URL that uses the FQDN is:
http://servername.company.com/exchange/username
When you use an FQDN, the tree-view page is loaded from host
servername. company.com, but the public folder location is set to servername on the page. The browser, therefore, interprets the access as being cross-domain. By default, Microsoft Internet Explorer security settings prevent cross-domain communication on the Internet.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Microsoft Exchange 2000 Server. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
301378 XGEN: How to Obtain the Latest Exchange 2000 Server Service Pack
WORKAROUND
There are three workarounds for this issue.
Method One
If you are using Secure Sockets Layer (SSL), you can allow cross-domain access for the mailbox site in Internet Explorer by doing the following:
- In Internet Explorer, click Internet Options on the Tools menu.
- On the Security tab, click Trusted sites, and then click Sites.
- Add your site to the zone.
- Click Custom Level.
- Under Miscellaneous/Access data sources across domains, click Enable.
Method Two
Deploy Exchange 2000 Server in a front-end and back-end environment. A front-end server accepts requests from clients, and then proxies them to the appropriate back-end server for processing. For information about deploying Exchange 2000 Server using front-end and back-end servers, please see the "Exchange 2000 Front-end and Back-end Topology" white paper available at the following Microsoft Web site:
Method Three
After you close the error dialog box, the folder tree list will function normally for the user's mailbox. To access public folders, open a Web browser, such as Internet Explorer, and type a URL directly to the public folders. The following is an example of such a URL:
http://servername.company.com/public
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange 2000 Server. This problem was first corrected in Microsoft Exchange 2000 Server Service Pack 1.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
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Keywords: | kbbug kberrmsg kbfix KB267569 |
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