PRB: OLAP Manager Add-in Options not Available for Certain Users (266775)



The information in this article applies to:

  • Microsoft SQL Server OLAP Services 7.0

This article was previously published under Q266775

SYMPTOMS

OLAP Manager add-in menu options, such as Archive/Restore and so forth, may not be available from OLAP Manager or the add-in menu options may not be visible for some users. The add-in dialog only displays Migrate Repository Wizard and three additional empty rows that have check boxes enabled or the add-in dialog may show nothing at all.

This problem only occurs for some users, even though the users are members of the OLAP Administrators group, the add-ins were installed correctly and the respective DLL files are installed in the \Olap services\Bin folder.

CAUSE

OLAP Manager add-in menu options (such as Archive/Restore and so forth) are not available in the OLAP Manager for those members of the OLAP Administrators group that are not also members of the local administrators group.

The user does not have enough permissions for the following registry keys:

HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\msmdarch
HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\addins\msmdcp
HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\addins\Command Editor

WORKAROUND

Add the user to the local administrators group and make sure that the OLAP Administrators group has full control permissions for the registry keys mentioned in the "Cause" section of this article.

MORE INFORMATION

When you have problems accessing an OLAP add-in, follow these steps:
  1. First, check to see if the respective add-in is installed correctly. To do this, look for the specific add-in DLL file in the \Olap services\Bin folder.
  2. Check to see if the add-ins are enabled in the Add-in Dialog in the OLAP Manager. To open the Add-in Dialog, right-click the Server folder in OLAP Manager, and then click Properties. A dialog box opens that has a series of tabs. In the dialog box, click the Add-in tab.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


If the add-in menu options are still not visible, one or more of the following registry keys probably do not have enough permissions:

HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info
HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\addins\MoveRepository
HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\addins\msmdarch HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\addins\msmdcp HKLM\Software\Microsoft\OLAP Server\OLAP Manager Info\addins\Command Editor

Give the OLAP Administrators users group Full Control to the preceding registry keys by using the RegEdt32 tool.

If giving the OLAP Administrators users group Full Control to the registry keys does not resolve the problem, you must add the user to the local administrators group.

Modification Type:MajorLast Reviewed:11/6/2003
Keywords:kbprb KB266775