The computer responds as if you double-clicked the mouse button when you try to single-click a Microsoft mouse button (266738)



The information in this article applies to:

  • Microsoft IntelliMouse
  • Microsoft IntelliMouse Explorer
  • Microsoft IntelliMouse with IntelliEye
  • Microsoft IntelliMouse Optical
  • Microsoft IntelliMouse Pro
  • Microsoft IntelliMouse TrackBall
  • Microsoft IntelliMouse USB
  • Microsoft IntelliMouse Web
  • Microsoft IntelliPoint Software version 4.1
  • Microsoft IntelliPoint software 1.0
  • Microsoft IntelliPoint software 1.1
  • Microsoft IntelliPoint software 2.0
  • Microsoft IntelliPoint software 2.1
  • Microsoft IntelliPoint software 2.0a
  • Microsoft IntelliPoint software 2.2c
  • Microsoft IntelliPoint software 2.2a
  • Microsoft IntelliPoint software 2.2d
  • Microsoft IntelliPoint software 2.2
  • Microsoft IntelliPoint software 3.1
  • Microsoft IntelliPoint software 3.2
  • Microsoft IntelliPoint software 3.0
  • Microsoft IntelliPoint software v.5.0
  • Microsoft IntelliPoint Software 5.1
  • Microsoft Laser Mouse 6000
  • Microsoft Notebook Optical Mouse
  • Microsoft Optical Mouse Blue
  • Microsoft Optical Mouse by Starck
  • Microsoft Wireless Desktop Version 1.0
  • Microsoft Wireless IntelliMouse Explorer 2.0
  • Microsoft Wireless Laser Desktop 6000
  • Microsoft Wireless Laser Desktop 6000 v2.0
  • Microsoft Wireless Laser Mouse 6000
  • Microsoft Wireless Laser Mouse 5000
  • Microsoft Wireless Notebook Laser Mouse 6000
  • Microsoft Wireless Notebook Optical Mouse
  • Microsoft Wireless Notebook Optical Mouse 4000
  • Microsoft Wireless Optical Desktop
  • Microsoft Wireless Optical Desktop 2.0
  • Microsoft Wireless Optical Desktop 5000
  • Microsoft Wireless Optical Desktop Comfort Edition
  • Microsoft Wireless Optical Desktop Elite
  • Microsoft Wireless Optical Desktop Pro
  • Microsoft Wireless Optical Desktop Pro 2.0
  • Microsoft Wireless Optical Mouse 2.0
  • Microsoft Wireless Optical Mouse 1000
  • Microsoft Wireless Optical Mouse 3000
  • Microsoft Wireless Optical Mouse 5000
  • Microsoft Wireless Optical Mouse Blue
  • Wireless Optical Desktop 3000

This article was previously published under Q266738

SYMPTOMS

When you try to single-click a Microsoft mouse button, the computer responds as if you double-clicked the mouse button.

CAUSE

This problem may occur for the following reasons:
  • You assume that you are performing a single physical click, when in fact, you are performing multiple clicks.
  • The mouse settings have been modified, either manually or by another program, to send a multiple-click command when you perform a single physical click.
  • The mouse drivers are corrupted.
  • The mouse hardware is defective.

RESOLUTION

To isolate the problem, use the following methods in the order that they appear in.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Method 1: Verify your clicking method

Make sure that you are performing a true single physical click. A single-click occurs when you press and release a mouse button one time.

Method 2: Test the mouse in multiple programs

Close all programs and test for the problem on the desktop and in other components of Microsoft Windows, such as Control Panel or Microsoft Windows Explorer.

If the problem only occurs in a particular program, troubleshoot that program. The program is most likely customizing the mouse commands.

Method 3: Test the mouse in safe mode

Microsoft Windows XP

To start Windows XP in safe mode, follow these steps:
  1. Click Start, click Shut Down, and then, in the drop-down list, click Shut Down.
  2. In the Shut Down Windows dialog box, click Restart, and then click OK.
  3. When you receive the following message, press the F8 key: Please select the operating system to start
  4. Use the arrow keys to select the appropriate safe mode option, and then press ENTER.
  5. If you have a dual-boot or multiple-boot system, select the installation that you have to access by using the arrow keys, and then press ENTER.

Microsoft Windows Millennium Edition, Microsoft Windows 98, and Microsoft Windows 95

The following method applies to Microsoft Windows Millennium Edition, Windows 98, and Windows 95 only. If you are running Microsoft Windows NT, continue to method 4.

To test the mouse in safe mode, follow these steps:
  1. Restart the computer.
  2. Immediately after the Power On Self Test (POST) beep, press F8 to display the Windows Startup Menu.

    Note The POST-beep is the single, short beep typically emitted as a computer starts. If you are not sure when to press F8, press this key every three seconds as the computer is starting. In Windows 98 or Windows Millennium Edition, you can also hold down the left CTRL key as the system is starting.
  3. Press 3, and then press ENTER.
  4. When you see the dialog box that states that you are running in safe mode, click OK.
  5. Test the mouse.
  6. To leave safe mode, restart the computer and let it start typically.
Note Certain programs and devices do not work in safe mode.

If the problem occurs in safe mode, continue to method 5.

If the problem does not occur in Safe mode, there is a software anomaly; continue to method 4.

Method 4: Troubleshoot your software

Check your mouse properties settings in Microsoft Windows

Make sure that Double-click or ClickSaver is not enabled. To do this, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.

    Note In Windows XP, click Start, and then click Control Panel.
  2. Double-click Mouse.
  3. Use the appropriate method for your version of IntelliPoint software.

    Version 2.2 or earlier

    On the StepSavers tab, click to clear the ClickSaver check box.

    Version 3.0 or a later version

    On the Buttons tab, under Button Assignment, make sure that the Left button setting is Click (default), and not Double-click.
  4. Click OK.

Check your desktop configurations

The operating system may support different desktop configurations (styles) that assign specific functions to your mouse-click commands. If the Web style configuration is currently enabled, a single physical click may be processed as a double-click. To verify this configuration, follow the appropriate steps for the operating system that you are using.

Windows XP
  1. Double-click My Computer.
  2. On the Tools menu, click Folder Options.
  3. On the General tab, make sure that Double-click to open an item (single click to select) is selected.
  4. Click Apply to save your settings change.
  5. Click OK.
  6. Close the My Computer dialog box.
Windows Millennium Edition
  1. Double-click My Computer.
  2. Click Folder Options on the Tools menu.
  3. Under Click items as follows, click Double-click to open an item (single-click to select).
  4. Click Apply to save your settings change.
  5. Click OK.
  6. Close the My Computer dialog box.
Windows 98, Windows 95, and Microsoft Windows NT
  1. Double-click My Computer.
  2. On the View menu, click Options or Folder Options.
  3. On the General tab, if Web Style is selected, click Classic Style.
  4. Click Apply to save your settings change.
  5. Click OK.
  6. Close the My Computer dialog box.

Close all background programs

In Microsoft Windows operating systems, remove memory-resident programs and other software that is loaded in the startup environment. The best way to do this is to perform a clean boot procedure. For more information about how to clean boot your version of Windows, click the following article numbers to view the articles in the Microsoft Knowledge Base:

243039 How to perform a clean boot in Windows 95

192926 How to perform clean-boot troubleshooting for Windows 98

267288 How to perform a clean boot in Windows Millennium Edition

310353 How to perform a clean boot in Windows XP

Remove and then reinstall the mouse drivers

Note In Windows 95, Windows 98, and Windows Millennium Edition, follow these steps in safe mode. See Method 3 for information about how to go into safe mode.

Remove the IntelliPoint Software
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add or Remove Programs.
  3. Double-click Microsoft IntelliPoint.
  4. Use the appropriate method for your version of IntelliPoint software.

    In version 2.2 or earlier

    1. Click Finish, and then click Close.
    2. Click Restart Windows.

    In version 3.0 or a later version

    1. Click Delete all files, and then click OK.
    2. Click Yes, I want to restart my computer now, and then click Finish.
Reinstall the IntelliPoint software
  1. Insert the IntelliPoint software disk.
  2. Click Start, click Run, type a:\setup in the Open box, and then click OK.
  3. Follow the instructions for the installation process.
  4. Restart the computer when you are prompted.

Reset the mouse buttons to their defaults

Note The steps below are for IntelliPoint software version 3.0 or later. You can download the latest IntelliPoint software at the following Microsoft Web site:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Mouse.
  3. On the Buttons tab, click Use Defaults.

    Note If Use Defaults is not available, all your button assignments are already set to default mode.
  4. Click OK.

Test the mouse in its diagnostic software

Note Mousinfo is included with IntelliPoint software version 3.0 or later.
  1. Click Start, click Run, type mousinfo in the Open box, and then click OK.
  2. Click the left mouse button.

    Under Last Mouse Message, WM_LBUTTONUP or WM_LBUTTONDLCLK appears for the double-click message.

    Note If the message does not appear when you click the left button, your mouse may be defective. See method 6.
  3. On the File menu, click Exit to close Mousinfo.

Method 5: Check mouse hardware and try swapping mouse ports if possible

Shut down the computer. Verify that the mouse cable is not damaged and that the pins on the end connector are not bent. Remove any mouse extension cables. If possible, try the mouse in a different port. Turn on your computer and retest.

Method 6: Test the mouse on another computer or test a different mouse on the computer

To determine whether the mouse or the computer is defective, follow these steps:
  1. Test the mouse in question on a system that you know is working. If the problem appears to follow the mouse, you may have to return or replace the mouse.
  2. Test a mouse that you know is working on the computer in question. If the problem appears to remain on the computer, then the problem is most likely software-related.

Modification Type:MajorLast Reviewed:10/5/2006
Keywords:kbHardware KB266738