FP2000: Error Message: No Server on Port <Number> at <Server Name> (266369)



The information in this article applies to:

  • Microsoft FrontPage 2000

This article was previously published under Q266369

For a Microsoft FrontPage 98 version of this article, see 194036.

SYMPTOMS

When you open or create a new FrontPage web in FrontPage, you may receive the following error message:
No server on port port number at server name.
where port number is the number of the port that you are connected to (the default port is 80), and server name is the name of the server.

CAUSE

You may receive this error message in any of the following cases:

Case 1

The Microsoft Personal Web Server is not running. Or, it is not running on the port that the error message specifies.

NOTE: There are two versions of the Microsoft Personal Web Server. Microsoft Personal Web Server 1.0 is included only with the FrontPage 98 CD-ROM. The updated version, Microsoft Personal Web Server 4.0, is included with the Microsoft Windows 98 CD-ROM or may be downloaded from the Microsoft Web site.

Case 2

The specified server does not exist, is not running, or does not have a Web server running on the port that issued the error message.

Case 3

The FrontPage Server Extensions are not installed on the FrontPage Personal Web Server.

RESOLUTION

Case 1

To resolve this problem, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
For Microsoft Personal Web Server 1.0
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Personal Web Server icon.
  3. Click the Startup tab.
  4. Click Start.
  5. Click to select the Show the Web server icon on the task bar check box.
  6. Click OK.

    NOTE: To confirm that the Personal Web Server is running, verify that the Personal Web Server icon appears in the System Tray (located at the opposite end of the Windows taskbar from the Start button).
For Microsoft Personal Web Server 4.0
  1. Browse to C:\WINDOWS\SYSTEM\inetsrv\pws.exe. (Pws.exe is the executable file for your Web server.)
  2. Double-click Pws.exe.
  3. In the Personal Web Manager, click Start.
  4. On the Properties menu, click Exit.

    NOTE: To confirm that the Personal Web Server is running, verify that the Personal Web Server icon appears in the System Tray (located at the opposite end of the Windows taskbar from the Start button).
For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

150684 FP: "No Server on Port ..." Error Opening, Creating Web Page

Case 2

To resolve this problem, follow these steps:
  1. Verify that you typed the correct Web server name.
  2. If you are attempting to connect to a remote server, verify that you are connected to the Internet. Verify any of the following that apply:

    • If you are connected to the Internet, verify that the Web server is up and the HTTP service is running.

      For information about how to test the connection between your computer and the Web server, follow the steps in the "More Information" section of this article.
    • If you are connected to a proxy server, verify that it is configured correctly for FrontPage Explorer. To do this, click Options on the Tools menu. In the Options dialog box, click Proxies. If you do not know which proxy settings you need to use, contact your network administrator.
    • If you are connected to a proxy server and you are accessing a server that is behind a firewall, verify that you specified that this server is on the intranet. To do this, follow these steps:

      1. On the Tools menu, click Options.
      2. In the Options dialog box, click Proxies.
      3. In the List of Hosts without Proxy box, type the name of the server. If the server is located on a port other than port 80, type a colon (:) and the port number after the server name, so that it looks similar to the following: server name:8080.

Case 3

The FrontPage Personal Web server will not start automatically if the FrontPage Server Extensions are not installed. To install the FrontPage Server Extensions, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Click Start, point to Find, and then click Files or Folders.
  2. In the Named box, type Fpsrvwin.exe. In the Look In list, select the hard disk on which you installed FrontPage. Click Find Now.
  3. In the list of files found, double-click the Fpsrvwin.exe file.
  4. In the FrontPage Server Administrator, click Install.
  5. In the Server Type list, click FrontPage Personal Web Server, and then click OK.
  6. In the Server Configuration dialog box, click Browse.
  7. Select the \FrontPage Webs\Server\Conf\Httpd.cnf file, and then click Open.
  8. Type a user name and password, and then click OK.

MORE INFORMATION

You can use a diagnostic tool such as ping (Packet Internet Groper) to determine whether your computer can communicate via TCP/IP to the server that you are attempting to access.

Ping is a low-level utility that informs you whether your computer and the server can communicate with each other and how long it takes for information to travel from one computer to the next. To use ping, follow these steps:
  1. Connect to the Internet.
  2. Click Start, point to Programs, and then click MS-DOS Prompt.
  3. At the command prompt, type the following:

    ping www.microsoft.com

    NOTE: You must be connected to the Internet in order to ping Microsoft.com. This procedure does not work if you are behind a firewall.
  4. If you receive either of the following messages, examine your TCP/IP stack, or contact your Internet Service Provider for assistance:
    - Destination host unreachable.

    -or-

    - Request timed out.

Modification Type:MajorLast Reviewed:8/6/2002
Keywords:kbprb KB266369