Desktop heap corruption causes "Stop 0x00000050" error message (266129)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q266129

SYMPTOMS

You may receive the following error message on a blue screen on a multiple-processor computer in a high-stress environment:
STOP:00000050 (fffffff8,00000000,00000000,00000000)

CAUSE

This symptom can be caused by a problem in Win32k.sys that causes desktop heap corruption.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time         Size  File name   Platform
   ----------------------------------------------------
   07-Dec-1999  04:38p  1,250,896  Win32k.sys  Intel
   07-Dec-1999  04:36p  2,049,904  Win32k.sys  Alpha

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/19/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB266129