Error Message Appears When Protected Storage Service Does Not Start (266055)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Windows 95
  • Microsoft Windows 98
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q266055

SYMPTOMS

When you restart a computer after installing a third-party software product, you may receive an error message explaining that the Protected Storage Service did not start. The exact error message varies, depending on the operating system (Windows 95, Windows 98, or Windows NT 4.0). However, the message indicates that the Protected Storage Service did not load.

In Windows NT Workstation 4.0, the error message generates the logging of Event 127, indicating that the service failed.

CAUSE

This behavior can occur when the Protected Storage Service is attempting to execute an application programming interface (API) call to an Imagehlp.dll file that does not exist in the older .dll files.

RESOLUTION

To resolve the issue, check for the presence of an Imagehlp.dll file in the Winnt\System32 folder for Windows NT or in the Windows\System folder for Windows 95 or 98.

MORE INFORMATION

The file's size and date should be as follows:

Windows NT Workstation 4.0, Internet Explorer 4.01: 104KB, 11/18/97
Windows NT Workstation 4.0, Internet Explorer 4.01, Service Pack 1: 104KB, 5/8/98
Windows 95 or 98: 112KB, 5/11/98

If the file is dated earlier than 1997, then either it needs to be replaced with the one from Internet Explorer 4.01 or you need to reinstall Internet Explorer 4.01.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kbprb KB266055