SMS: Client Configuration Manager Does Not Append .ccr to the Client Configuration Request (265882)
The information in this article applies to:
- Microsoft Systems Management Server 1.2
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
- Microsoft Systems Management Server 2.0 SP2
This article was previously published under Q265882 SYMPTOMS
If the initial installation for a client that is a member of a domain name that is composed of less than four characters is unsuccessful, the resulting retry may not be processed. Under these conditions, Client Configuration Manager (CCM) does not append the .ccr file extension to the Client Configuration Request (CCR) when it is moved to the SMS\Inboxes\Ccrretry.box folder (the file name remains as netbiosname. domainname). This problem occurs only under the following site configurations:
- Systems Management Server (SMS) 2.0 with Service Pack 2 applied.
- SMS 2.0 with Service Pack 1 (build 1380) and the hotfix described in Q252717 applied.
- SMS 2.0 (build 1239) and the hotfix described in Q252718 applied.
If the initial client installation attempt is successful, this problem does not occur. Unless you use the workaround described in this article, unsuccessful client installations are not retried until a new CCR is generated. A new CCR is created when a new Discovery Data Record (DDR) for the unsuccessful client installation is received and processed by Discovery Data Manager. A DDR is created during the next installation attempt by Smsman, Logon Installation, or Remote Client Installation.
CAUSE
This behavior occurs because CCM checks to see if an extension already exists on a file before appending .ccr to the file name. The component assumes that a file name with three characters or less already has a file extension and does not need .ccr appended to the end of the file.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
288239 SMS: How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUND
To work around this issue, use the following steps on the site server:
- Manually stop the CCM service by using Service Manager under the Tools node of the SMS Administrator console.NOTE: You can also stop the SMS Executive service as an alternative because CCM is a subthread of the SMS Executive service.
- Create a batch file to add the .ccr extension to the end of the computername.domainname file.
- Restart the service that you stopped in step 1 (either the CCM or SMS Executive service).
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Systems Management Server 2.0 Service Pack 3.
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbBug kbClient kbConfig kbDiscovery kbfix kbServer kbsetup kbsms200preSP3fix kbUpgrade KB265882 |
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