Windows Me Setup Blocks WinPoET or Enternet 300 Because of Compatibility Issues (265804)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q265804

SYMPTOMS

When you are upgrading to Microsoft Windows Millennium Edition (Me), you may receive either of the following error messages:
Setup has determined that the version of Enternet 300 has known compatibility issue when installed on Windows Me. It is recommended that you contact your ISP for compatible versions before upgrading to Windows Me.

-or-

Setup has determined that the version of WinPoET installed on your computer has known compatibility issues on Windows Me. Before upgrading, It is recommended that you contact your ISP about obtaining an upgrade to the latest version of WinPoET.
You cannot continue Setup until you install a compatible version of Enternet 300 or WinPoET.

If you try to install these programs after Windows Me Setup has finished, you receive the following error message:
This program does not run correctly on this version of Windows. To continue, click Run Program. To exit, click Cancel. For more information, click Details.
NOTE: You will not have access to your DSL connection until you install a compatible version of WinPoET or Enternet 300.

CAUSE

Older versions of WinPoET and Enternet 300 are not compatible with Windows Me because of changes in the operating system.

RESOLUTION

Contact your Internet service provider (ISP) to obtain an updated version of the software that is compatible with Windows Me.

If you are unable to install an updated version of WinPoET (for example, if you are unable to start Windows), and a reinstallation of Windows is necessary, you must first remove the WinPoET software. To remove WinPoET and finish Windows Setup, use the following procedure.

NOTE: If you are able to start Windows, use only step 8 through step 10. If you are unable to start Windows, follow all the steps.
  1. Insert a startup disk into the appropriate drive. Restart your computer. On the Startup menu that appears, select Start computer with CD-ROM support, and then press ENTER.For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

    267287 How to Create a Startup Disk in Windows Me

    296532 How to Create a Windows 98 Startup Disk


    186300 How to Create a Windows 98 Startup Disk from MS-DOS

  2. Prepare to edit the System.ini file. To do so, type the following command, and then press ENTER:

    edit windir\system.ini

    where windir is the directory that Windows is installed in (usually C:\windows).
  3. In the editor, locate this line below the [boot] section:

    shell=explorer.exe

    Change the line to:

    shell=progman.exe

  4. Press ALT+F to access the File menu. Press S to Save. Press ALT+F, and then press X to Exit.
  5. Restart the computer as usual (do not use the boot disk). The computer will start with Program Manager open.
  6. In Program Manager, on the File menu, click Run. Type the following line, and then click OK:

    control appwiz.cpl

    The Add/Remove Programs tool will open.
  7. In Add/Remove Programs, locate the WinPoET software and remove it.
  8. Quit the Add/Remove Programs tool and close Program Manager. Again perform step 1 through step 3, but this time change the line in the System.ini file back to shell=explorer.exe.
  9. Run Setup again to reinstall Windows.

MORE INFORMATION

WinPoET, Enternet 300, and Access Manager are Point-to-Point protocol (PPP) over Ethernet (PPPoE) programs that are used to gain access to high-speed broadband networks.

The following versions are compatible with Windows Me:
  • Enternet 300: Versions later than 1.34
  • WinPoET: Versions with a build number later than 20000407
  • Access Manager: Versions later than 1.2
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/28/2004
Keywords:kb3rdparty kberrmsg kbFAQ kbprb kbsetup KB265804