Parallel Port Devices Do Not Work After You Upgrade from Windows NT 4.0 (265409)



The information in this article applies to:

  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q265409
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you upgrade from Windows NT 4.0 to Windows 2000, parallel port (LPT) devices may not be detected. The port appears in Device Manager as "Parallel output only" or ECP 1.x with an exclamation mark in a yellow circle. The properties of the LPT device appear as:

The drivers for this device are not installed. (Code 28)

To reinstall the drivers for this device, click Reinstall Driver.

If you click Reinstall Driver, you may receive the following error message:
The name is already in use as either a service name or a service display name.

CAUSE

This issue can occur if software that is included with the Hewlett-Packard (HP) PhotoSmart series of printers is installed on your computer before you upgrade to Windows 2000.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, contact HP to inquire about the availability of a fix for this issue.

To work around this issue:
  1. Click Start, click Run, type regedit, and then press ENTER.
  2. View the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

  3. In this key, click the hphparnt value, press DELETE, and then click Yes to confirm the deletion.
  4. Quit Registry Editor.
  5. Right-click My Computer, and then click Manage.
  6. Click Device Manager, right-click the LPT device, and then click Uninstall.
  7. Restart your computer.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/4/2003
Keywords:kb3rdparty kberrmsg kbHardware kbPlugPlay kbprb kbUpgrade w2000device w2000pnp w2000upgrade KB265409