Slow network performance occurs when you select a file on a share that uses NTFS (265396)



The information in this article applies to:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Server SP3
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Professional SP3

This article was previously published under Q265396

SYMPTOMS

When you select a file on a network share that uses an NTFS file system partition, extra Server Message Block (SMB) packets are sent on the wire. This behavior causes overall slow network performance.

The same issue occurs if you browse the network, and you position the mouse cursor over one of the files; however, this issue does not occur if you use a Microsoft Windows NT 4.0-based client computer.

CAUSE

This issue occurs because Microsoft Windows Explorer tries to open NTFS streams on the volume to get extended information about the file, for example, title, subject, comments, and source author. All of this information for the file is stored on the volume.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date        Time   Version        Size       File name
  --------------------------------------------------------
  05/20/2002  16:25  5.0.3502.5772  2,350,864  Shell32.dll
Note When you install this hotfix, the hotfix installer will make a registry change that turns off the Summary Properties Page. Removing the hotfix will restore the original registry setting.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

Follow these steps on all client computers that use the products that are listed at the beginning of this article:
  1. Install the hotfix, and then restart the computer when you are prompted.
  2. On the Tools menu in Windows Explorer, click Folder Options.
  3. In the Folder Options window, click the View tab, and then make sure that the Show pop-up description for folder and desktop items check box is not selected.
  4. Click the General tab, and then click the Use Windows Classic Folders check box.
  5. Click OK to close the Folder Options window.
  6. Follow the steps in the "Resolution" section of the following Microsoft Knowledge Base article:

    829700 Slow network performance when you open a file that is located in a shared folder on a remote network computer


    Note For the best performance, perform step 6 after you apply Windows 2000 SP4 on the client computer.
Note These additional steps are required because if you select Show pop-up description for folder and desktop items or if you do not select Use Windows Classic Folders, this creates extra traffic on the network, even after you apply the hotfix.

When you a select a file, the following information is displayed on the wire:

SMB C NT create & X, File = \dnscrcli.lib
SMB R NT create & X, FID = 0x800f
SMB C transact2 Query file info, FID = 0x800f
SMB R transact2 Query file info (response to frame 5)
SMB C NT create & X, File = \dnscrcli.lib:Raec25ph4sudbf0hAaq5ehw3Nf:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:Raec25ph4sudbf0hAaq5ehw3Nf:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:{4c8cc155-6c1e-11d1-8e41-00c04fb9386d}:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:SummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:Docf_SummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:SummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:Docf_SummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:SummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:Docf_SummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:DocumentSummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
SMB C NT create & X, File = \dnscrcli.lib:Docf_DocumentSummaryInformation:$DATA
SMB R NT create & X - NT error, System, Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND
					

These attempts to open hidden data streams are designed to extract the data required for displaying pop-up descriptions, the Explorer status line, and certain Properties dialog pages. After the hotfix is applied, the Summary, Custom, and Security pages of the Properties dialog will never be displayed, because it is not possible to create these Properties pages without the data from the eliminated traffic. For more information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the following article number to view the article in the Microsoft Knowledge Base:

265173 The Datacenter Program and Windows 2000 Datacenter Server product

For more information about how to install multiple hotfixes with only one restart, click the following article number to view the article in the Microsoft Knowledge Base:

296861 How to install multiple Windows updates or hotfixes with only one reboot

For more information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the following article number to view the article in the Microsoft Knowledge Base:

249149 Installing Microsoft Windows 2000 and Windows 2000 hotfixes


Modification Type:MajorLast Reviewed:1/3/2006
Keywords:kbHotfixServer kbQFE kbshell kbbug kbfix kbnetwork kbWin2000preSP4Fix KB265396