OL98: Outlook Makes Duplicate Appointments After You Apply a Hotfix (265011)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q265011

SYMPTOMS

Outlook can sometimes produce a duplicate appointment for a meeting request if you send the meeting request as one of the occurrences of a recurring appointment that was not made as meeting item. This behavior can occur when you are using Outllib.dll version 8.5.6119 or later.

CAUSE

Outllib.dll version 8.5.6119 or later uses a PR_OWNER_APPT_ID property in restriction when searching an associated appointment item. However, after the recurrence item is not made as meeting item, the item does not have the PR_OWNER_APPT_ID property. If you use Outllib.dll version 8.5.6119 or later causes Outlook not to search the associated appointment item with the PR_OWNER_APPT_ID property. As the result, the meeting request is recognized as a different meeting from the original appointment item, and the meeting is duplicated. This behavior is corrected by Outllib.dll version 8.5.8028.0.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The Japanese version of this fix should have the following file attributes or later:
   Date       Time      Version      Size       File name    Platform
   -------------------------------------------------------------------
   8/29/2000  20:47:20  8.5.8028.0   6,625,552  Outllib.dll  Windows9x/NT
				

WORKAROUND

Upgrade to Microsoft Outlook 2000.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce the Problem

  1. Create a mailbox called UserA on a Microsoft Exchange Server 5.5 computer.
  2. Install Outlook 98. (This problem is language independent.)
  3. Apply QFE build 6119 or later.
  4. Start Outlook 98 and log on to the Exchange Server computer as UserA.
  5. Create a recurring appointment in the calendar.
  6. Open one of the occurrences with the Open this occurrence option.
  7. Click the Attendee Availability tab, and then add UserA to the attendees.
    You will see two UserA's in the Attendees list.
  8. Send the meeting request.
  9. Open the meeting request.
Result: You receive the following message, and the meeting is duplicated.

"Please respond."
"Conflicts with another appointment on your Calendar."

Expected Result: You receive the following message, and the meeting is not registered in the calendar.

"No responses have been received for this meeting."


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB265011