SYMPTOMS
In Microsoft Team Manager, when you send or open an e-mail message such as Team member settings or a Task Update, you may receive either or both of the following warning messages:
Message 1
Microsoft Outlook
A program is trying to access e-mail addresses you have stored in Outlook. Do you want to allow this?
If this is unexpected, it may be a virus and you should choose "No".
Message 2
Microsoft Outlook
A program is trying to automatically send e-mail on your behalf. Do you want to allow this?
If this is unexpected, it may be a virus and you should choose "No".
NOTE: Depending on the type of e-mail message that you send or open, you may see multiple instances of each of these warning messages.
When you click
Yes on each of these warning messages, your e-mail messages are sent or opened normally.
If you click
No in response to message 1 or message 2, you may see one or more of the following error messages:
Error 1: When You Send a Message from Team Manager or Team Manager for Team Members
Unable to send workgroup mail to name.
Error 2: When You Open a Message in Outlook
There was a problem opening your e-mail message. You may be out of memory, or a problem may have occurred with your e-mail program.
To increase memory, close programs or windows not necessary to your work.
If you still encounter memory problems, save your work, close all programs, and then quit and restart Microsoft Windows.
Error 3: When You Reply to a Message in Outlook
A problem occurred while sending your reply message. To send your message again, restart Team Manager for team members, click Options and then click Resend Lost or Missing Messages.
CAUSE
This behavior occurs if you have installed the Outlook
E-mail Security Update. The Outlook E-mail Security Update
provides additional levels of protection against malicious
e-mail messages. The update changes the way that
Outlook handles attachments and the way that Outlook
can be controlled programmatically.
For additional information about
this update, please see one of the following articles
in the Microsoft Knowledge Base, depending on which
version of Outlook you have:
262631 OL2000: Information About the Outlook E-mail Security Update
262617 OL98: Information About the Outlook E-mail Security Update
WORKAROUND
To work around this behavior, use one of the following methods as appropriate for your situation.
Outlook Messages Stored on Exchange Server
If you are running Outlook in a Microsoft Exchange Server environment, and your e-mail messages are delivered to a server-based mailbox, your Exchange Server administrator can configure specific features that are included with the Outlook E-mail Security Update.
NOTE: Because these features affect other programs besides Microsoft Team Manager, administrative changes to these features may result in increased security risks. Your Exchange Server administrator should consider the advantages and disadvantages of configuring specific features before implementing them for Microsoft Team Manager users.
For more information about how to control the Outlook E-mail Security Update in an Exchange Server environment, click the article numbers below to view the articles in the Microsoft Knowledge Base:
263297 OL2000: Administrator Information About the Outlook E-mail Security Update
263296 OL98: Administrator Information About the Outlook E-mail Security Update
To control the interaction of the Outlook E-mail Security Update with Microsoft Team Manager e-mail messages, as well as with other programs that use Simple MAPI, an Exchange Server administrator can modify some of the options located on the
Programmatic Settings tab of the Default Security Update interface.
To avoid the warning messages listed in the "Symptoms" section of this article when you send or open Microsoft Team Manager e-mail messages, the setting
Automatically approve must be selected for the following four features:
- When sending items via Simple MAPI
- When resolving names via Simple MAPI
- When opening messages via Simple MAPI
- When accessing address information via Outlook object model
Outlook Messages Not Stored on Exchange Server
If you are not running Outlook in a Microsoft Exchange Server environment, or if your mail is delivered to a local Personal Folders file (.pst), you cannot configure the settings for the update. You must either use the full feature set of the update, or remove the update by uninstalling and reinstalling Outlook as described later in this article.
How to Remove the E-mail Security Update for Microsoft Outlook 98
Because Microsoft Outlook 98 shipped as an independent product, completely uninstalling and reinstalling Outlook 98 removes the Outlook E-mail Security Update components.
How to Remove the E-mail Security Update for Microsoft Outlook 2000
If Outlook 2000 is the only Office 2000 program that is installed on your system, completely uninstalling and reinstalling Outlook 2000 removes the update.
If Outlook 2000 was installed along with other Office 2000 programs, you must completely remove and reinstall all of Office 2000.
NOTE: Repairing Outlook 2000 or Office 2000 does not remove the Outlook E-mail Security Update.