FIX: #DELETED Error When Inserting Records with CHAR Primary Key (264766)
The information in this article applies to:
- Microsoft Access 2000 Service Release 1 (SR-1)
- Microsoft Access 2002
This article was previously published under Q264766 SYMPTOMS
When you insert a new record into a linked ODBC table that has a fixed-length text field (CHAR) as the primary key, #DELETED appears in all of the fields in the new record.
Note If you then close and reopen the linked table, the newly inserted record appears and is properly inserted.
CAUSE
Many ODBC drivers add spaces to (or "pad out") a CHAR field when the number of characters that are inserted is less than the maximum length of the field. Microsoft Jet 4.0 incorrectly reads back the inserted, padded value and compares it with the original, unpadded value. Because the two values are different, Jet reports to Microsoft Access that the newly inserted record cannot be found.
RESOLUTION
To resolve this problem, install the latest Jet 4.0 service pack.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
239114
How To: Obtain the Latest Service Pack for the Microsoft Jet 4.0 Database Engine
WORKAROUND
Use a variable-length text field (VARCHAR) as the primary key for the table.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was fixed in Jet 4.0 Service Pack 6 (SP6).
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbBug kbDatabase kbfix kbJET KB264766 |
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