"Your device was not detected" message displayed in the Get Connected Wizard (264693)



The information in this article applies to:

  • Microsoft ActiveSync 3.1, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows 98
  • Microsoft ActiveSync 3.5
  • Microsoft ActiveSync 3.6
  • Microsoft ActiveSync

This article was previously published under Q264693

SYMPTOMS

When you attempt to synchronize a Microsoft Windows CE-based device that is using a universal serial bus (USB), after you run the Get Connected Wizard by clicking Get Connected on the File menu in ActiveSync, you may receive the following message:
Your device was not detected. Verify that the connection you are using is available.
Below the message, you may see a listing of the available ports and their status. The USB port is listed as
USB is available.
however, the Windows CE-based device will still be unable to establish a connection by using a USB.

In Device Manager, in the Other Devices node, the properties for the USB device may display the device status, "Code 28."

CAUSE

If the USB cradle or cable is connected to the USB port prior to the installation of ActiveSync 3.1, a USB device will be detected and the Add New Hardware Wizard will start. However, the correct USB drivers for Windows CE will not be available for installation. The correct USB drivers can only be detected after you have installed ActiveSync 3.1 on the desktop system. An invalid entry is added to the hardware tree in the registry for the phony USB device.

This will be reflected in Other Devices node in Device Manager. A USB Device will be listed as "Code 28." This is the entry for the CE device, and it will be displayed each time an attempt is made to connect the device by using a USB. The phony USB device blocks the installation of the proper CE USB components and drivers provided by the ActiveSync 3.1 installation.

RESOLUTION

You need to remove and redetect the device. To do so, follow these steps:
  1. Right-click My Computer, click Properties, and then click the Device Manager tab.
  2. In the Device Manager window, expand Other Devices, and then double-click USB Device. Under Device status, you see the error, "Code 28." Click Remove.
  3. Restart the computer.
  4. In Device Manager, click Refresh. This will force the operating system to look for any new devices, and it should detect the CE device attached to the cradle or cable. After the USB device is detected, this is followed by another dialog box that states that the xxUSB Sync has been located, and that the drivers will be installed from the ActiveSync 3.1 directory.
  5. Follow the provided directions, and then connect the CE device. The device should be automatically detected, and then the wizard will start.

    Note that if the Other Devices node with the USB Device is not listed in Device Manager, cycle the power on the CE device. After the CE device is off, the listing will disappear. If the power is on the CE Device, but there is still no listing in Device Manager, be sure to click Refresh. After this, proceed with steps 1 through 4.
  6. In some instances, it is necessary to start the Windows 98 computer in Safe mode to remove the Other Devices node from Device Manager. You can remove the USB driver by pressing the F8 key during startup, and accessing Device Manager. However, you should only do this if these steps do not resolve the issue.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbenv kberrmsg kbHardware kbprb KB264693