Visio2000: "The Solution Failed to Load, Please Make Sure MSDE Is Properly Installed" Error When You Open AutoDiscovery and Layout Solution (264680)



The information in this article applies to:

  • Microsoft Visio 2000 Enterprise Edition

This article was previously published under Q264680

SYMPTOMS

When you open the "AutoDiscovery and Layout" solution, you may receive the following error message:
The solution failed to load, please make sure MSDE is properly installed.

CAUSE

You receive this error message under the following conditions:
  • You delete or move any .mdf file from either the \WINNT\Profiles\All Users\Application Data\Visio\AutoDiscovery folder or the \MSSQL7\Data folder.
  • The Microsoft Data Engine (MSDE) is not properly registered during installation.

RESOLUTION

To correct this problem, do the following:
  1. Stop SQL Server Service Manager.
  2. Remove MSDE.
  3. Reinstall MSDE.
  4. Restart SQL Server Service Manager.
To stop SQL Server Service Manager:
  1. Quit Visio, and then open SQL Server Service Manager by double-clicking the MSSQLServer icon in the system tray.
  2. In the SQL Server Manager dialog box, click to clear the Auto-start service when OS Starts check box.
  3. Stop MSSQLServer Service manager, and click Yes when you are asked if you are sure that you want to stop SQL Server Manager.
  4. Right-click the MSSQLServer icon in the system tray, and then click Remove Startup shortcut.
  5. Restart Windows.
To remove MSDE:
  1. Click Start, point to Settings, click Control Panel, and then double-click Add Remove Programs.
  2. Select MSDE, and then click Add/Remove.
  3. Click No to ALL when you are prompted to remove the shared file Replprov.dll.
  4. Open Windows Explorer, delete the MSSQL7 folder, and then click Yes to confirm that you want to delete it.
  5. Click Yes again.
To reinstall MSDE:
  1. Insert the Microsoft Visio 2000 Enterprise Edition CD into your CD-ROM or DVD-ROM drive.
  2. Click Start, point to Run, click Browse, and browse to your CD-ROM or DVD-ROM drive.
  3. Browse to the \Install\bin\sp\MSDE folder.
  4. Copy the MSDE folder to drive C.
  5. Click Start, and then click Run.
  6. In the Open box, type C:\MSDE\MSDEx86.exe -s -a -f1 "C:\MSDE\unattend.iss", and then click OK.
  7. On computers that are running Microsoft Windows NT and Microsoft Windows 2000, open Task Manager by pressing CTRL+ALT+DEL, and wait for MSDEx86.exe to disappear from the Processes list.
  8. Restart Windows.
To restart SQL Server Service Manager:
  1. Open SQL Server Service Manager by double-clicking the MSSQLServer icon.

    NOTE: If the MSSQLServer icon does not appear in the system tray, you may have to reinstall MSDE again.
  2. In the SQL Server Manager dialog box, click to select the Auto-start service when OS Starts check box.
  3. Start SQL Server Service Manager by clicking Start/Continue.

Modification Type:MajorLast Reviewed:10/19/2000
Keywords:kberrmsg KB264680