Protected Storage Always Prompts for Password After Using GhostWalker (264033)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0

This article was previously published under Q264033
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After you use GhostWalker to deploy Windows NT Workstation, and you change the computer's security ID (SID), you may receive the following prompt every time you log on to a Web site where user information is stored (such as Microsoft Hotmail):
Protected Storage uses your Windows password to protect your personal data.
Protected Storage has detected data created with a previous version.
To continue to use this data, enter your Windows password below.

CAUSE

This behavior occurs because the Access Control lists (ACLs) on certain registry entries and files may not be reset by GhostWalker.

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this issue, follow these steps:
  1. Reset the protected storage ACLs. To do this:
    1. Start Registry Editor (Regedt32.exe).
    2. Locate and click the following registry setting:

      HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider

    3. On the Security menu, click Permissions.
    4. Click to select the Replace Permissions on Existing Subkeys check box, and then click OK.
    5. Delete the Protected Storage System Provider key.
  2. Rebuild the protected storage. To do this:
    1. Start Internet Explorer, and then click Internet Options on the Tools menu.
    2. Click the Content tab, and then click AutoComplete.
    3. Click Clear Forms, and then click Clear Passwords.
    4. Click OK, and then click OK.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kb3rdparty kbprb KB264033