OFF2000: "Program Not Found" Error Message When You Start Office Program (263930)



The information in this article applies to:

  • Microsoft Excel 2000
  • Microsoft Access 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Publisher 2000
  • Microsoft Word 2000

This article was previously published under Q263930

SYMPTOMS

When you try to start a Microsoft Office program, you may receive an error message similar to the following
Windows cannot find Program.exe.

This program is needed for opening files of type 'Application'.

Location of Program.exe:
where Program.exe corresponds to the name of the program that you are trying to start, such as Winword.exe.

CAUSE

This error message may occur when all of the following conditions are true:
  • When you installed Office, the installation state of the program was set to Run from Network or Run all from Network.
  • The network location from which the program runs was not available at one time, which forced the Windows Installer to use a backup location. For example, the network server was shut down, the network server was disconnected from the network, or the Office folder on the server was deleted or renamed.
  • All resilient network source locations for the Office Setup files were unavailable when you started your computer.
  • The original network location where Office was originally installed is now available.

RESOLUTION

This problem is resolved in Windows 2000 Service Pack 2 (SP2). Apply the latest service pack for Windows 2000 to all of the workstations. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

When you start your computer, the Windows Installer validates any sources that you have specified for the Office Setup files, and then caches the available locations in memory. Because of this, network sources that are unavailable may not be validated until you restart your computer. The only way to clear this cache is to restart your computer.

Modification Type:MajorLast Reviewed:6/28/2004
Keywords:kbbug kbpending KB263930