Error Message: Initializing Device IOS Windows Protection Error (263466)
The information in this article applies to:
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
- Microsoft Windows 95
This article was previously published under Q263466
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages: 315854 Windows 98 and Windows Me Error Message Resource Center
SYMPTOMS
When you start your computer, you may receive the following error message:
Initializing Device IOS: Windows Protection Error
When you try to restart your computer in Safe mode, you may receive the same error message.
CAUSE
This issue can occur if a virus hooked the INT21h or INT13h chain before Microsoft Windows is loaded, an unsafe device driver is detected, or a protected-mode driver is missing or damaged in the Iosubsys file located in the Windows\System\Iosubsys folder.
RESOLUTION
To resolve this issue, you must minimize the amount of time to locate the origin of this error message, as well as other error messages. First, focus on any obvious changes that occurred in your computer just before you received the error message. If you installed new software or hardware, the installation process may have performed some action that may be the cause of your computer's current problem.
The same situation may have occurred if you removed outdated software or hardware. If changes occurred in your computer, revert to your original configuration prior to the display of the error message. For example, if you installed a new processor, install the previous processor back into your computer and observe if the error message is resolved when you restart your computer. NOTE: If the error is resolved, contact the hardware manufacturer to ensure that you are using the most recent basic input/output system (BIOS) for your computer.
After you have eliminated the preceding behavior as the potential source of your computer's problem behavior, try to restart your computer in Safe mode by performing the following steps:
- Restart your computer. For a Microsoft Windows 95-based computer, when you observe the "Starting Windows 95" message, press F8, and then on the Startup menu, click Command Prompt Only. For a Microsoft Windows 98-based computer, press and hold down the CTRL key after your computer is finished the power-on self test (POST), and then on the Startup menu, click Command Prompt Only.
- If you receive the same error message when you try to restart your computer in Safe mode, go to the next step (Step 3). If you can restart your computer in Safe mode, clean boot your computer to identify the cause of your issue.
For additional information about how to perform a clean boot, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
243039 How to Perform a Clean Boot in Windows 95
192926 How to Perform Clean-Boot Troubleshooting for Windows 98
- Make a Bootlog.txt file and examine it to identify the cause of the error. Restart your computer using the steps outlined in the preceding step 1 and when the Startup menu is displayed, click Step-By-Step Confirmation.
-
Press Y and ENTER after each line is displayed:
- Load DriveSpace Driver?
- Process the system registry?
- Create a Startup Log file (Bootlog.txt)?
- Process your Startup device drivers (Config.sys)?
- Device=path\Himem.sys?
- Device=path\Ifshlp.sys?
- Device=path\Dblbuff.sys?
- Device=path\Setver.exe?
- Process your Startup command file (Autoexec.bat)?
- Load the Windows graphical user interface?
- Load all Windows drivers?
- Restart your computer using the preceding step 1, and then on the Startup menu, click Command Prompt Only.
- Use the command prompt to view the C:\Bootlog.txt file to identify the problem. At the command prompt, type:
Press ENTER, and then examine the Bootlog.txt file for "Initcomplete=" entries. These entries may provide clues as to the cause of the problem.
Each "Initcomplete=" entry must have a matching "Initcompletesuccess=" entry on a successful start up of your system. If the last line in the Bootlog.txt file displays an "InitFailure" or "LoadFailure" message for a driver, write down the driver's name, exit the Bootlog.txt file, press ALT+F, press X, click OK, and then search for the driver.
NOTE: Some virtual device drivers (VxDs) are required for Windows to run properly. These required VxDs are loaded automatically and do not require a registry entry. If one of the following drivers are listed as "LoadFailure", go to Step 9.
Windows 98 Drivers
*VDD *VFLATD *VSHARE
*VWIN32 *VFBACKUP *VCOMM
*COMBUFF *VCD *VPD
*SPOOLER *UDF *VFAT
*VCACHE *VCOND *VCDFSD
*INT13 *VXDLDR *VDEF
*DYNAPAGE *CONFIGMG *NTKERN
*EBIOS *VMD *DOSNET
*VPICD *VTD *REBOOT
*VDMAD *VSD *V86MMGR
*PAGESWAP *DOSMGR *VMPOLL
*SHELL *PARITY *BIOSXLAT
*VMCPD *VTDAPI *PERF
*VKD *VMOUSE *MTRR
*ENABLE
Windows 95 Drivers
*BIOSXLAT *CONFIGMG *DYNAPAGE
*DOSMGR *EBIOS *IFSMGR
*INT13 *IOS *PAGESWAP
*SHELL *V86MMGR *VCD
*VCACHE *VCOMM *VCOND
*VDD *VDMAD *VFAT
*VKD *VMCPD *VPICD
*VTD *VTDAPI *VWIN32
*VXDLDR
- If the driver is not in the preceding list, try to rename the driver and restart Windows. At the command prompt, type the following command and press ENTER after each command line:
dir /s driver name
where driver name is the name of the driver with an "Init Failure" or "Load Failure" message in the Bootlog.txt file.
- Type the following commands and press ENTER after each command line:
cd Path ren driver namedriver name.old
where Path is the path of the driver with an "Init Failure" or "Load Failure" message in the Bootlog.txt file.
- If you do not find any unsuccessful attempts in the Bootlog.txt file, or if after you rename a file you still receive the error, try to locate an Ios.log file in the Windows directory. The Ios.log file may help you to identify a virus or it may contain information describing why the protected-mode disk driver could not load.
For additional information about the Ios.log file, click the article number below
to view the article in the Microsoft Knowledge Base:
138899 Description of the Ios.log File
- If the preceding steps do not resolve your issue, try to install Windows into a new folder to verify whether or not it is compatible with your current hardware configuration.
For additional information about how to install Windows into a new folder, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
142096 How to Reinstall Windows 95 to a New Folder
193902 How to Install Windows 98 Into a New Folder
NOTE: If you receive an error message when you attempt to install Windows into a new folder, your hardware may need to be inspected by a professional technician.
Modification Type: | Minor | Last Reviewed: | 1/15/2006 |
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Keywords: | kberrmsg kbHardware kbprb kbWinProtectErr KB263466 |
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