You receive an "Error 1316. A network error occurred" error message when you upgrade an existing installation to Office 2000 SR-1 Full Install Product (263253)



The information in this article applies to:

  • Microsoft Office 2000 (Setup) Service Release 1 (SR-1)

This article was previously published under Q263253
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry



NOTE: Modifying the registry entry may require Administrator privileges. Please see your system administrator if you are unable to modify the registry.

SYMPTOMS

When you run Setup for the Office 2000 SR-1 Full Install Product (not the SR-1/SR-1a Update) on a computer where Office is already installed, you may receive an error message similar to the following:
Error 1316. A network error occurred while attempting to read from the file F:\data1.msi

CAUSE

You may receive this error message if the following are true:
  • You originally installed Office with a CD-ROM that contained Data1.msi on the root of the CD. This is the default file name used for the Office CD1 Windows Installer package.
  • You are running the Office SR-1 Setup by using a Select CD.
The Office 2000 SR-1 Select CD does not use Data1.msi. Instead, there are a series of .msi and Setup files on the root, each one named according to the edition of Office to be installed. For example, if you want to install the Premium edition from the Select CD, you run Setupprm.exe, which uses Data1prm.msi.

WORKAROUND

To work around this problem, do one of the following, depending on the source of your SR-1 Setup files.

Install Directly from the Select SR-1 CD

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

If you are using the Select SR-1 CD to update your existing installation of Office, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type Regedit and click OK.
  3. On the Edit menu, click Find.
  4. In the Find what box, type Data1.msi and then click Find Next.
  5. If the search result selects a string value called PackageName, continue with these steps. Otherwise, repeat steps 3-4.
  6. Double-click the PackageName string value.
  7. In the Value data box, type the name of the .msi package that you are using on the Office 2000 SR-1 Select CD, and then click OK. For example, if you are trying to install the Premium edition, type Data1prm.msi.
  8. The PackageName string value is part of the SourceList key. Select the Media key that is a subkey of the SourceList key.
  9. Double-click the 1 string value.
  10. In the Value data box, type Selo9cd01;1 and then click OK.
  11. On the Registry menu, click Exit.
  12. Run the appropriate Setup again from the Office 2000 SR-1 Select CD.

Install from an Administrative Installation Created by the Select SR-1 CD

If you want create an administrative installation of SR-1 by using the Select CD, follow these steps:
  1. Insert your SR-1 Select CD.
  2. Click Start, and then click Run.
  3. In the Open box, type a command line similar to the following:

    CD-ROM drive:\Setupprm.exe /a

    where CD-ROM drive is the drive letter of your CD-ROM drive. Also, the Setup program that is specified on the command line varies according to the edition of Office that you are installing. In the above example, Setupprm.exe is used to install Office Premium.
  4. Enter your company name, and then click Next.
  5. Accept the license agreement, and then click Next.
  6. Type the location for your SR-1 administrative installation, and then click Install Now.
  7. When the administrative installation is finished, rename the .msi file on the root of the administrative installation to Data1.msi. For example, if you created an administrative installation of Office Premium, you would rename Data1prm.msi to Data1.msi.
  8. Using a text editor, open the Setupedition.ini file on the root of the administrative installation.

    NOTE: edition is a three-letter abbreviation for the edition of Office that you are using. For example, if you created an administrative installation of Office Premium, this file is called Setupprm.ini.
  9. In the [MSI] section of the .ini file, change the MSI= line so that it points to Data1.msi. For example, if you created an administrative installation of Office Premium, the original line would be:

    MSI=data1prm.msi

    You would change this line to:

    MSI=data1.msi

  10. Save and close the .ini file.
  11. From your network client, run the Setup for Office 2000 SR-1 from the administrative installation that you just created.

MORE INFORMATION

You can also receive the error message in the "Symptoms" section of this article if you are trying to create an administrative installation by using the SR-1 Select CD, and you also have Office 2000 installed on the client from which you are running the administrative Setup. This is only true if you are trying to create an administrative installation by using the same edition of Office that is already installed on your client from which you are running the administrative Setup. For example, this occurs if you have Office 2000 Premium installed from the original Office 2000 CD on your computer, and then you start an administrative Setup from the SR-1 Select CD by using Setupprm.exe.

To work around this issue, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type Regedit and then click OK.
  3. On the Edit menu, click Find.
  4. In the Find what box, type Data1.msi and then click Find Next.
  5. If the search result selects a string value called PackageName, continue with these steps. Otherwise, repeat steps 3-4.
  6. Double-click the PackageName string value.
  7. In the Value data box, type the name of the .msi package that you are using on the Office 2000 SR-1 Select CD, and then click OK. For example, if you are trying to install the Premium edition, type Data1prm.msi.
  8. On the Registry menu, click Exit.
  9. Run the administrative Setup again by using the SR-1 Select CD.
  10. After your administrative installation is finished, click Run on the Start menu.
  11. In the Open box, type Regedit and then click OK.
  12. On the Edit menu, click Find.
  13. In the Find what box, type Data1prm.msi and then click Find Now.NOTE: If you did not use Data1prm.msi in step 7, type the appropriate .msi string for your edition of Office in the Find what box.

  14. If the search result selects a string value called PackageName, continue with these steps. Otherwise, repeat steps 12-13.
  15. Double-click the PackageName string value.
  16. In the Value data box, type Data1.msi and then click OK.
  17. On the Registry menu, click Exit.
The following table lists the different .msi and Setup files on the root of the Office 2000 SR-1 Select CD for each of the different Office and standalone editions:
   Office Edition     .msi package     Setup file
   --------------------------------------------------
   Premium            Data1prm.msi    Setupprm.exe
   Professional       Data1pro.msi    Setuppro.exe
   Standard           Data1std.msi    Setupstd.exe
   Access             Data1acc.msi    Setupacc.exe
   Excel              Data1exl.msi    Setupexl.exe
   FrontPage          Data1fpg.msi    Setupfpg.exe
   Outlook            Data1out.msi    Setupout.exe
   PowerPoint         Data1ppt.msi    Setupppt.exe
   Word               Data1wrd.msi    Setupwrd.exe
   
				

Modification Type:MinorLast Reviewed:9/14/2004
Keywords:kberrmsg kbtshoot kbsetup kbnofix kbprb kbpubtypekc kbmsccsearch KB263253