Games: You receive the "Setup was unable to find (or could not read) the language specific setup resource dll, unable to continue" error message when you try to install a Microsoft game (262622)



The information in this article applies to:

  • Links 2003 Championship Edtn EN
  • Microsoft Age of Empires II: The Age of Kings 2.0
  • Microsoft Age of Empires II Expansion: The Conquerors
  • Microsoft Age of Empires II Gold Edition
  • Microsoft Allegiance 1.0
  • Microsoft Baseball 2001
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft Crimson Skies
  • Microsoft Dungeon Siege II
  • Microsoft Golf 2001 Edition
  • Microsoft Links 2001
  • Microsoft Links 2003
  • Microsoft Links 2003 Championship Edition
  • Microsoft MechWarrior 4: Mercenaries
  • Microsoft MechWarrior 4: Vengeance
  • Microsoft Metal Gear Solid
  • Microsoft Midtown Madness 2 2.0
  • Microsoft Motocross Madness 2 2.0
  • Microsoft Pandora's Box 1.0
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft StarLancer 1.0
  • Microsoft Train Simulator
  • Microsoft Zoo Tycoon
  • Microsoft Zoo Tycoon: Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs Expansion Pack
  • Microsoft Zoo Tycoon: Marine Mania Expansion Pack
  • Microsoft Zoo Tycoon 2: Endangered Species

This article was previously published under Q262622

SYMPTOMS

When you try to install one of the Microsoft games listed in the "Applies to" section, you may experience any one of the following symptoms:
  • You may receive an error message that contains only an exclamation point (!).

    When you click OK, the Setup program quits.
  • You receive an error message that contains an exclamation point and the word, "Start".
  • A dialog box for a different Microsoft game appears instead of the dialog box for the game that you are trying to install.
  • You may receive the following error message:
    Setup was unable to find (or could not read) the language specific setup resource dll, unable to continue. Please reboot and try again.

CAUSE

This issue may occur if one of the following conditions is true:
  • The Microsoft Windows Temp folder is damaged.
  • There is more than one file on your hard disk that uses the Setupenu.dll file name.
  • You download a patch that is corrupted.

    Note You may receive the following error message if you download a patch that is corrupted:
    Setup was unable to find (or could not read) the language specific setup resource dll, unable to continue. Please reboot and try again.

RESOLUTION

To resolve this issue, use the following methods.

Delete the Temp folder

To delete the Temp folder on the computer, use the appropriate method for your version of Microsoft Windows.

Microsoft Windows XP or Microsoft Windows 2000

Note The temporary folder is located in each specific user folder (for example, C:\Documents and Settings\user name\Local Settings\Temp). To empty the Windows temporary folder, follow these steps:
  1. Click Start, click Run, type %temp% in the Open box, and then click OK.
  2. On the Edit menu, click Select All.
  3. On the File menu, click Delete.
  4. Click Yes when you are prompted with the following message: Are you sure you want to send these items to the Recycle Bin?
  5. Set up the game.

Microsoft Windows 98 or Microsoft Windows Millennium Edition (Me)

To empty the Windows temporary folder, follow these steps:
  1. Click Start, click Run, type temp in the Open box, and then click OK.
  2. On the Edit menu, click Select All.
  3. On the File menu, click Delete.
  4. Click Yes when you are prompted with the following message: Are you sure you want to send these items to the Recycle Bin?
  5. Set up the game.

Restart the computer by using a clean boot procedure

When you start Microsoft Windows, typically there are a number of programs that start automatically and run in the background that may interfere with the game. These programs may include antivirus and system utility programs. When you perform a clean boot procedure, you prevent these programs from starting automatically. You must be logged on as an administrator or as a member of the Administrators group to complete this procedure. If the computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To restart the computer by using a clean boot procedure, follow these steps when you are using Windows XP.

Note You may experience a temporary loss of some services functionality when you follow these steps. Restoring the settings restores the functionality, but may result in the return of the original error message or behavior.
  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective Startup.
  3. Under Selective Startup, click to clear the following check boxes:
    • Process SYSTEM.INI File
    • Process WIN.INI File
    • Load Startup Items
  4. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  5. Click OK, and then click Restart.
Click Play to view this streaming media demonstration.

For more information or to view steps for other operating systems, click the following article number to view the article in the Microsoft Knowledge Base:

331796 Games: How to perform a clean boot to prevent background programs from interfering with play

Rename the Setupenu.dll files

  1. Click Start, point to Find, and then click Files or Folders.
  2. In the File name box, type setupenu.dll.
  3. In the Look in box, click My Computer or click Local hard drives, and then click Find Now.
  4. In the list of found files, right-click a copy of the Setupenu.dll file, and then click Rename.
  5. Type oldsetupenu.dll, and then press ENTER.
  6. Repeat steps 4 and 5 to rename each copy of the Setupenu.dll file in the list of found files.
  7. Insert the CD for the game that you want to install into the CD or DVD drive.

    If the Setup program does not start automatically, follow these steps:
    1. Click Start, click Run, type the following line in the Open box, and then click OK:

      cd-rom:\setup.exe

      where cd-rom is the drive letter of your CD-ROM or DVD-ROM drive.
    2. Follow the instructions that appear on the screen to install the game.
  8. Click Start, point to Find, and then click Files or Folders.
  9. In the File name box, type oldsetupenu.dll.
  10. In the Look in box, click My Computer or click Local Hard Drives, and then click Find Now.
  11. In the list of found files, right-click a copy of the Oldsetupenu.dll file, and then click Rename.
  12. Type setupenu.dll, and then press ENTER.
  13. Repeat steps 11 and 12 to rename each copy of the Oldsetupenu.dll file in the list of found files.

Download the patch again

If you received the "Setup was unable to find..." error message that is listed in the "Symptoms" section, and you have recently downloaded a patch for your game, download the patch again to make sure that you received the correct patch.

For more information about how to troubleshoot Setup errors, click the following article number to view the article in the Microsoft Knowledge Base:

258496 Games: How to troubleshoot Setup problems in Microsoft games


Modification Type:MajorLast Reviewed:8/2/2006
Keywords:kbhowto kbArtTypeSHOWME kbenv kbprb kbsetup KB262622