OL2000: Password Expires with No Prompt to Change Password (262611)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q262611
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you are logged on to the network and your password expires, when you try to start Outlook 2000, many event ID 535 messages may be generated and logged in the server Security log.

In Outlook 2000, the User Credential dialog box in which you can change your password may not be displayed; instead, a Network Error dialog box is displayed.

CAUSE

This problem can occur if the Microsoft Exchange Server address provider state computer does not handle the invalid user credentials correctly.

RESOLUTION

To resolve this problem, obtain the latest service pack for Microsoft Office 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

276367 OFF2000: How to Obtain the Latest Office 2000 Service Pack

To enable the users to change the password, you must enable the registry entry, later in this article, on the Primary Domain Controller.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To enable this fix, modify the following registry entry on the domain controller:
  1. Start Registry Editor (Regedt32.exe).
  2. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  3. On the Edit menu, click Add Value, and then add the following value:

    Value Name: TCPIPClientSupport
    Data Type: REG_DWORD
    Value: 0x0, 0x1
    Default: 0x0 (not in registry by default)
    Description: Enable LSA to have a NCACN_IP_TCP end point registered

  4. Click OK, and then quit Registry Editor.
  5. Quit and restart the primary domain controller.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

After you apply the fix, you may notice a reduction in the Event ID 535 on the server security log. You may also notice that Outlook 2000 now displays User Credential dialog box; however, the user may be unable to change the password. For additional information about this problem, click the article number below to view the article in the Microsoft Knowledge Base:

236111 XCLN: Client Unable to Change Windows NT Password


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbOffice2000preSR2fix kbQFE KB262611