Universal Serial Bus (USB) Disconnect Icon Does Not Show on First Boot (261800)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q261800
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

After the installation Microsoft Windows Millennium (Me), if you are using a Hewlett Packard Universal Serial Bus CD Read-Writeable (HP USB CDRW) drive, no Disconnect icon is displayed on the system tray.

CAUSE

The CDRW drive is using the Hewlett-Packard USB storage driver, which does not call the Microsoft Hotplug applet for removing the device.

RESOLUTION

Switch to Microsoft drivers, using the Update drivers option in Device Manager. To perform this action, follow these steps:
  1. Right-click the My Computer icon, and then click Properties.
  2. Click the Device Manager tab, scroll down to the HP USB CDRW device, and then double-click the HP USB CDRW device.
  3. Click the Drivers tab, and then click Update Driver.
  4. Click Specify the location of the driver (Advanced), and then click Next.
  5. Click Display a list of all the drivers in a specific location, click the driver you want, and then click Next.
  6. On the Update Device Driver Wizard, click the Show All Hardware option.
  7. In the list of manufacturers, click Microsoft.
  8. In the list of models, click USB Mass Storage Device, and then click Next.
  9. Once the driver is installed, restart the system.

WORKAROUND

To work around this issue, use of the following methods:
  • During an upgrade to Windows Millennium, leave the HP drivers in place.

    -or-
  • During an upgrade to Windows Millennium, install the HP drivers first, and then install the drive.

    -or-
  • If a clean install of Windows Millennium is done, connect the HP CDRW and then connect the Microsoft USB storage drivers.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kb3rdparty kbHardware kbprb kbui KB261800