Offline defragmentation in Exchange 2000 Server or in Exchange Server 5.5 fails because of lack of space (261681)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • Microsoft Exchange Server 5.5

This article was previously published under Q261681

SYMPTOMS

When you run eseutil /d to defragment an Exchange Server database, the process may fail with an error that indicates a lack of disk space. This behavior may occur even though you use the /t switch to redirect the temporary defragmentation database to a drive with plenty of free space. For more information about defragmenting a database, click the following article number to view the article in the Microsoft Knowledge Base:

192185 How to defragment with the Eseutil utility (Eseutil.exe)

CAUSE

Besides the temporary database created during defragmentation (called Tempdfrg.edb, by default), when you run eseutil /d, a file named Tmp.edb is also created in the directory where you run Eseutil from. Eseutil uses this file for transient storage, indexing, or sorting data, and the Tmp.edb file is normally very small. If the directory where you run Eseutil from is low on disk space, the space consumed by the Tmp.edb file can cause the operation to end.

WORKAROUND

Run the command from a drive with more free disk space.

REFERENCES

For more information about the Eseutil command, click the following article number to view the article in the Microsoft Knowledge Base:

183888 Free disk space requirements for Eseutil.exe


Modification Type:MajorLast Reviewed:5/2/2005
Keywords:kbprb KB261681