XFOR: Unsynchronized Mailbox Index Files Cause MCIS Message Expiry to Fail in Random Ways (261238)



The information in this article applies to:

  • Microsoft Commercial Internet System 2.0

This article was previously published under Q261238

SYMPTOMS

Microsoft Commercial Internet System (MCIS) message expiry fails in the following ways:
  • New messages are deleted by expiration.
  • Old messages are not deleted by expiration.
  • After expiration has run, mailbox is over quota and no longer receives mail.

CAUSE

MCIS exclusively uses the Inbox.idx file for all calculations and file date and time values. If the Inbox.idx becomes unsynchronized with the physical files in the mailbox, the expiration process might make incorrect decisions about which files to expire. Also for IMAP mailboxes, the mailbox quota can be exceeded before expiration is run, but this might not be detected because of an unexpected flag setting in the Inbox.idx file. After expiration has run, flags are reset, which can cause a mailbox that was over quota not to be detected until expiration has run.

All issues are caused by Inbox.idx files that are unsynchronized with the actual physical files in the mailbox. This can be caused by manual manipulation of *.eml files and *.idx files.

RESOLUTION

There are two ways to resolve this issue:
  • Delete all *.idx files. MCIS will rebuild then the next time the mailbox is accessed.
  • Contact Microsoft Product Support Services.

Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbprb KB261238