Terminal Services Client May Not Connect with "Server Too Busy" Error Message (260746)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server

This article was previously published under Q260746

SYMPTOMS

When you use the Windows 2000 Terminal Services client to connect to the Terminal Services computer, you may receive the following error message:
Terminal Services Client Disconnected

The client could not connect to the Terminal Server. The server may be too busy. Please try connecting later.

CAUSE

This behavior can occur if the client is attempting to connect to an Internet Protocol (IP) address that does not belong to the Terminal Services computer. The Terminal Services client may try to connect to a different IP address, if a different IP address is returned for the address of the Terminal Services computer during the name resolution process.

RESOLUTION

To resolve this issue, use the following steps:
  1. Verify the name you are using to connect to the Terminal Services computer is correct, and that it resolves to the correct IP address.
  2. Create a hosts file using Edit (from a command prompt), and then save the file to the %SystemRoot%\System32\Drivers\Etc folder in Microsoft Windows NT or Windows 2000, or the Windows folder in Microsoft Windows 95/98. For example:

    x.x.x.x TSServer

    NOTE: Where x.x.x.x is the IP address of the Terminal Services computer and TSServer is the name of the Terminal Services computer.
  3. Verify connectivity to the Terminal Services computer by IP address.

    NOTE: Also try to connect to the Terminal Services computer by IP address using the Terminal Services client when no DNS servers are specified in the TCP/IP properties/preferred or alternate DNS servers. The Terminal Services client may try to resolve the Terminal Services computer's IP address using host name resolution, which may be resolved to a different IP address by a DNS server.

MORE INFORMATION

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

169790 How to Troubleshoot Basic TCP/IP Problems in Windows NT 4.0


Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbenv kberrmsg kbprb KB260746