"Access Code" Error Message Printing to Networked Printer (260737)
The information in this article applies to:
- Microsoft Windows Millennium Edition
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
- Microsoft Windows 95
This article was previously published under Q260737 If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware: IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you try to print to a network printer that is connected to a Hewlett-Packard (HP) JetDirect interface, you may receive the following error message:
There was an error writing to \\Servername\Printername for printer Printer Model: the access code is invalid. This printer will be set to work offline. To save your printer job in the local printer queue, click OK.
This problem does not occur if you print a test job from the printer, or from a Microsoft Windows NT-based computer.
CAUSE
This behavior can occur if the JetDirect printer is configured incorrectly, or if the printer spooler has become corrupted.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve the problem, delete the printer, remove the printer entries from the registry, and then re-create the printer:
- On the computer that is running Windows 95/Windows 98, click Start, point to Settings, and then click Printers. Click the printer with which the issue is occurring, and then click Delete on the File menu. Confirm the deletion by clicking Yes.
- On the Windows NT-based computer, click Start, point to Settings, and then click Printers. Click the printer with which the issue is occurring, and then click Delete on the File menu. Confirm the deletion by clicking Yes.
- Delete the printer from the following registry location:
HKEY_LOCAL_MACHINE\system\CurrentControlSet\control\print\environments\winnt\Windows NT x86\drivers\version-2
NOTE: If Windows NT is running on a RISC processor, the location of the printer is:
HKEY_LOCAL_MACHINE\system\CurrentControlSet\control\print\environments\winnt\Windows NT Alpha_AXP\drivers\version-2
- On the Windows NT-based computer, delete the printer drivers located in the Winnt\System32\Spool\Drivers\W32x86\2 folder.
- Reinstall the printer in Windows NT printer by using the Microsoft-supplied or HP-supplied supplied drivers.
- Re-create the printer on the computer running Windows Me/98/95.
NOTE: In some cases, you may need to delete and then re-create the JetDirect port after trying the method listed above.
Modification Type: | Major | Last Reviewed: | 8/8/2006 |
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Keywords: | kberrmsg kbprb kbprint KB260737 |
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