PhD Error Message: Another Version of This Product Is Already Installed (260374)



The information in this article applies to:

  • Microsoft PhotoDraw 2000
  • Microsoft PhotoDraw 2000 2.0

This article was previously published under Q260374
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to upgrade to a later version of Microsoft PhotoDraw 2000, you may receive the following error message:
Another version of this product is already installed.

The installation of this version cannot continue.

CAUSE

This behavior can occur if the installation of the previous version of PhotoDraw is damaged. If this is true, PhotoDraw Setup cannot uninstall the previous version of PhotoDraw.

RESOLUTION

To resolve this issue, uninstall the previous version of PhotoDraw.

To do this, use the following methods in the order in which they are presented:

Use PhotoDraw Setup to Uninstall PhotoDraw

To use PhotoDraw Setup to uninstall PhotoDraw:
  1. Insert the CD-ROM for the previous version of PhotoDraw into your CD-ROM drive. Press and hold down the SHIFT key when you insert the CD-ROM to prevent PhotoDraw from starting automatically.
  2. Click Start, and then click Run.
  3. In the Open box, type the following line, and then click OK

    drive:/setup.exe

    where drive is the drive letter of your CD-ROM drive.
  4. Click Remove or Remove All to uninstall the previous version of PhotoDraw.

    NOTE: If Setup starts in Install mode, use the Typical installation option to install PhotoDraw. Follow the instructions on the screen until Setup is finished, and then repeat steps 2 through 4 to uninstall the previous version of PhotoDraw.
  5. Install the later version of PhotoDraw.
If the issue continues to occur, proceed to the next method.

Manually Uninstall PhotoDraw

To manually uninstall PhotoDraw:

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
  1. Double-click the My Computer icon on the desktop.
  2. Double-click the hard disk on which PhotoDraw is installed.
  3. Double-click the Program Files folder.
  4. Double-click the Microsoft Office folder.
  5. Double-click the Office folder.
  6. Right-click the PhotoDraw folder, and then click Delete. When you are prompted to confirm the folder deletion, click Yes.
  7. Start Registry Editor.
  8. Delete the following registry keys (if they exist):
    • HKEY_CURRENT_USER\Software\Microsoft\PhotoDraw
    • HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\PhotoDraw
    • HKEY_LOCAL_MACHINE\Software\Microsoft\PhotoDraw
    • HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\PhotoDraw

  9. Quit Registry Editor.
  10. Close all open windows on the desktop.
  11. Install the later version of PhotoDraw.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kberrmsg kbprb kbsetup KB260374