FIX: Replication Agents May Fail With Arithmetic Overflow Errors Due to Large Latencies (260342)
The information in this article applies to:
This article was previously published under Q260342
BUG #: 57515, 58059 (SQLBUG_70)
SYMPTOMS
The replication agents logreader and distribution might fail with the following error message:
Code 1007: Arithmetic overflow error converting %ls to data type %ls
CAUSE
When the delivery latencies of replication agents are high, the stored procedures that compute average delivery latency report the following error message:
Error 8115 Sev 16 Arithmetic overflow error converting %ls to data type %ls.
WORKAROUND
Locate the history table in the distribution database that corresponds with the type of agent that is failing.
The logreader agent uses the mslogreader_history system table and the distribution agent uses the msdistribution_history system table.
Set the delivery_latency value found in the history table to zero for the row with the latest "time" value in the time column for a given agent_id. For example:
update MSdistribution_history set delivery_latency=0 where agent_id=1 and time =(select max(time) from MSdistribution_history where agent_id=1)
The agent_id should be appropriately selected from distribution..msdistribution_agents.
The preceding workaround temporarily resolves the problem by allowing the agent to run but does not prevent the problem from happening again.
STATUS
Microsoft has confirmed this to be a problem in SQL Server 7.0. This problem has been corrected in U.S. Service Pack 3 for Microsoft SQL Server 7.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base: 274799 INF: How to Obtain Service Pack 3 for Microsoft SQL Server 7.0 and Microsoft Data Engine (MSDE) 1.0
For more information, contact your primary support provider.
Modification Type: | Major | Last Reviewed: | 3/14/2006 |
---|
Keywords: | kbBug kbfix kbQFE KB260342 |
---|
|