Client Services for NetWare Does Not Run Logon Script After Initial Boot (260206)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
This article was previously published under Q260206 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
If a user that has Client Services for NetWare (CSNW) or Gateway Service for Netware (GSNW) installed on a Windows 2000-based computer attempts to log on immediately after boot, the NetWare logon scripts do not run. If the client logs off and then logs back on, or waits for a few minutes before logging on, the scripts run as expected.
CAUSE
This behavior occurs when the Netlogon process starts before the NWCWorkstation process (the CSNW client).
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this issue, use the following steps:
- Run Registry Editor (Regedt32.exe).
- Locate the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServiceGroupOrder
- Double-click the List value in the right frame, and then scroll down the Multi-String Editor box until you see the NetBIOSGroup item.
- Click NetBIOSGroup, move to the end of the line, and then press ENTER to add a blank line.
- Type networkprovider, and then click OK.
- Locate the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NWCWorkstation
- On the Edit menu, click Add Value, and then add the following value information:
Value Name: Group
Data Type: REG_SZ
Value: NetworkProvider
- Quit Registry Editor and restart the computer for the changes to take effect.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Windows 2000.
Modification Type: | Major | Last Reviewed: | 11/20/2003 |
---|
Keywords: | kbbug kbenv kbNetWareService KB260206 |
---|
|