OL98: (CW) Microsoft Mail Service Is Not Available (260165)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q260165
NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".

SYMPTOMS

When you attempt to add the Microsoft Mail service to a profile, Microsoft Mail may not be in the list of available services.

CAUSE

A missing, damaged, or invalid file may cause this problem.

RESOLUTION

Add or rename, and then replace the Msfs32.dll file and the Mapisvc.inf file.

If these files are not on your computer, skip the first six steps of this procedure. If the Msfs32.dll file and the Mapisvc.inf file are on your computer, you must rename the files:
  1. Click Start, and then click Shut Down.
  2. In the Shut Down Windows dialog box, click Restart the computer in MS-DOS mode, and then click Yes.
  3. When your computer restarts, type cd\windows\system at the command prompt, and then press ENTER.
  4. At the command prompt, type ren msfs32.dll msfs32.old, and then press ENTER to rename the Msfs32.dll file.
  5. At the command prompt, type ren mapisvc.inf mapisvc.old, and then press ENTER to rename the Mapisvc.inf file.
  6. At the command prompt, type exit, and then press ENTER.
You must add the files to the System folder:
  1. On the Start menu, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs, click the Install/Uninstall tab, click Microsoft Outlook 98, and then click Add/Remove.
  3. In the Maintenance Wizard, click Add New Components.
  4. If you are prompted, click Install From CD or Install From Web.
  5. If you are prompted to have Active Setup check for installed components, click Yes.
  6. After Setup checks your installed components, click to select the Microsoft Mail 3.x Support check box under Mail Components.
  7. When you receive the following message, click Yes:
    Microsoft Mail 3.x Support is already installed.
    Do you want to reinstall this component?

MORE INFORMATION

To verify or install the Microsoft Mail Service:
  1. Start Outlook.
  2. On the Tools menu, click Services.
  3. Confirm that the Microsoft Mail service is in the list of available information services.
  4. If the Microsoft Mail Service is not in the list of available information services, click Add.
  5. In the Add Service to Profile box, click to select the Microsoft Mail Service check box in the list of available services.
If Microsoft Mail is not listed, follow the steps in the "Resolution" section of this article.

Modification Type:MajorLast Reviewed:5/3/2000
Keywords:kbprb KB260165