Windows Stops Responding During Shutdown with Mapped Drives (260067)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95
  • Microsoft Windows 98

This article was previously published under Q260067
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you shut down Windows and you have a significant number of mapped network drives (network drives that have been assigned a local drive letter), the computer may stop responding (hang). Note that this problem is more likely to occur as the number of mapped drives increases. The threshold that has been reported most often is eight mapped drives.

NOTE: In Windows 98, there is a very small possibility that this problem can occur when any of the following occurs:
  • You update the display driver, then restart Windows.
  • You change the display font size, then restart Windows.
  • A 16-bit application program calls the Win16 API ExitWindows function with the EW_RESTARTWINDOWS flag.
NOTE: To more effectively search the Microsoft Knowledge Base, use keywords that relate to your issue. If you are searching for troubleshooting information that is not mentioned in this article, search the Microsoft Knowledge Base again by using keywords that are listed in the following Microsoft Knowledge Base article:

242450 How to Query the Microsoft Knowledge Base Using Keywords

CAUSE

This problem can occur because during the shutdown process, a WM_DEVICECHANGE message is broadcast to all top-level windows. This broadcast informs each window of a DBT_DEVICEREMOVECOMPLETE event. If a window does not respond to the broadcast system message, the computer may stop responding (hang).

Under the conditions described in the "Symptoms" section of this article, the operating system kernel may shut down while broadcast messages are still queued for delivery. This causes all input processing operations to stop, which precludes any window from responding (and causes Msgsrv32 to hang).

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
Date        Time    Version    Size     File name   Platform
--------------------------------------------------------------------------- 
04/21/2000  11:33a  4.10.2227   55,296  User32.dll  Windows 98 Second Edition
04/19/2000  04:02p  4.10.2227  549,760  User.exe    Windows 98 Second Edition
	

NOTE: There are no planned updates for Windows 98 at this time. Please refer to the "Workaround" section.

WORKAROUND

To work around this problem, upgrade to Microsoft Windows Millennium Edition (Me), or disconnect all mapped network drives before you shut down Windows.

STATUS

Microsoft has confirmed that this is a problem in Windows 98 Second Edition.

This problem was corrected in Windows Millennium Edition.

MORE INFORMATION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

The update causes the shutdown thread to wait for a default value of 1,000 milliseconds before initiating kernel shutdown, if it detects that message broadcasts are pending. The value cannot be changed on Windows 95 (all versions), which has a default value of 1,500 milliseconds). On Windows 98 Second Edition, you can override this default value by using the following registry entry:

Key: HKEY_CURRENT_USER\Control Panel\Desktop
Value: ShutDownWaitTime
Type: DWORD
Data: Number of milliseconds to delay before kernel shutdown

This article and the update it describes supercedes the following Microsoft Knowledge Base article:

242934 Windows Hangs Sending System Broadcast Message During Shutdown

For additional information on how to obtain and install the Windows 98 Second Edition Shutdown Supplement, click the article number below to view the article in the Microsoft Knowledge Base:

239887 Windows 98 Second Edition Shutdown Supplement

For additional information about troubleshooting Windows 98 and Windows 98 Second Edition shutdown problems, click the article number below to view the article in the Microsoft Knowledge Base:

202633 How to Troubleshoot Windows 98 Shutdown Problems

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes

For additional information about Windows 95 hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

161020 Implementing Windows 95 Updates


Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbHotfixServer kbQFE kbbug kbenv kbfix kbnetwork KB260067