Unable to log on to Instant Messaging using domain name only (258861)



The information in this article applies to:

  • Microsoft Exchange 2000 Server
  • the operating system: Microsoft Windows NT 4.0 SP6a
  • the operating system: Microsoft Windows 98
  • the operating system: Microsoft Windows 98 Second Edition

This article was previously published under Q258861

SYMPTOMS

When you try to log on to an Instant Messaging server that is running Microsoft Windows NT 4.0, Microsoft Windows 98, or Microsoft Windows 98 Second Edition (SE), and you use the format

username@domain.com

instead of

username@servername.domain.com

you may receive the following error message:
Logon to Microsoft Exchange Instant Messaging failed because the service is not responding. The service is not available or you may not be connected to the Internet.

CAUSE

These operating systems are not natively equipped with the ability to perform Domain Name System (DNS) service location (SRV) record queries.

RESOLUTION

On a Windows NT 4.0, Windows 98, or Windows 98 Second Edition operating system, you must install the Active Directory Client Extension. The Active Directory Client Extension provides DNS SRV record query capabilities. For additional information about how to install the appropriate Active Directory Client Extension, click the following article number to view the article in the Microsoft Knowledge Base:

288358 How to install the Active Directory Client Extension

MORE INFORMATION

The Dsclient.exe program (Active Directory Client Extension) also provides the files that you need to perform a first-name/last-name Instant Messaging contact search.

Modification Type:MinorLast Reviewed:5/6/2004
Keywords:kberrmsg kbprb KB258861 kbAudITPRO