OFF2000: Odd Behavior on Windows 2000 After You Install Office 2000 SR-1 Update (258549)



The information in this article applies to:

  • Microsoft Office 2000 (Setup) Service Release 1 (SR-1), when used with:
    • the operating system: Microsoft Windows 2000

This article was previously published under Q258549

SYMPTOMS

After you install the Microsoft Office 2000 Service Release 1 Update on a computer that is running Windows 2000, you may see any of the following symptoms:
  • When you click hyperlinks in Microsoft Outlook messages, Microsoft Word documents, and Microsoft PowerPoint presentations, Internet Explorer does not start.
  • Nothing happens when you click Start, point to Search, and then click For Files or Folders.
  • Nothing happens when you click Start, point to Search, and then click On the Internet.
  • When you attempt to open a Web page in a new window in Internet Explorer, a new window is not opened.
  • You cannot view Microsoft Outlook full screen or maximize the window.
  • The Office Assistant fails to shut down when you quit an Office program.
  • When you right-click the Office Assistant within an Office program, the Office program shuts down.
  • Nothing happens when you click Find in Internet Explorer.

CAUSE

These symptoms can occur when the following files are not registered properly:
  • Oleaut32.dll
  • Olepro32.dll
  • Msjet40.dll
  • Msjtor40.dll
  • Dao360.dll
  • Stdole2.tlb
NOTE: These symptoms occur if the following are all true:
  • You installed Office 2000 on a Windows NT 4.0 computer.

    -and-
  • You upgraded from Windows NT 4.0 to Windows 2000.

    -and-
  • You applied the Office 2000 Service Release 1 Update (SR-1).

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Download the Microsoft Office 2000/Windows 2000 Registry Repair Utility

A utility that automates the process of registering these files is available. The following file is available for download from the Microsoft Download Center:
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Method 2: Register the Files Manually

To register the files manually, follow these steps:
  1. Click Start on the Windows taskbar.
  2. Click Run.
  3. In the Open box, type the following command, and then click OK:

    RegSvr32 <filename>

    where <filename> is the name of the file that you are registering.

    You should receive a message that the file is now correctly registered.

Modification Type:MinorLast Reviewed:8/11/2004
Keywords:kbdownload kbfix kbprb KB258549