Office 2000 programs quit immediately on Windows 2000 when you are logged on as user (257593)



The information in this article applies to:

  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Publisher 2000
  • Microsoft Word 2000
  • the operating system: Microsoft Windows 2000

This article was previously published under Q257593
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start a Microsoft Office program, the following may occur:

The program starts, but after a few seconds, the following error message appears:
Required registry information is missing and this application cannot run. Please run setup to correct this problem.
When you click OK, the error message goes away, but the program immediately quits.

CAUSE

You may experience these symptoms if all of the following are true:
  • You are using Windows 2000.
  • You are logged on as a user.
  • Your administrator applied the Always install with elevated privileges policy (AlwaysInstallElevated) to Computer Configuration and User Configuration.
  • You ran Setup from a CD-ROM.
Note You may also encounter this problem on Windows 2000 if your administrator used a CD-ROM and advertised Office using the /j switch (for example, <CD-ROM drive>\Setup /jm). In this scenario, you are prompted to enter the CD-Key when you first start an Office program. Then the error message appears.

If you ran Setup from a CD-ROM and you are logged on as a user, you do not have the necessary permissions to write the Office license registration information into the Windows registry.

RESOLUTION

If you already installed Office and you are experiencing these symptoms, please use one of the following methods to resolve this issue.

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Method 1: You are Using the AlwaysInstallElevated Policy

  1. Log on as the user who installed Office.
  2. On the Start menu, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. In the Add/Remove Programs dialog box, click Office 2000, and then click Remove.
  5. After Office has been removed, log on as an administrator.
  6. Start the Registry Editor and delete the following key:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0

  7. Close the Registry Editor and log on as the original user.
  8. Run Office Setup from an administrative installation of Office. Because the license registration process is different when you install Office from an administrative installation, the necessary registry information exists when you start the Office programs.

    Note You cannot work around this problem by applying the PIDKEY property (on the command line, in a transform, or in the Setup.ini file) when you install Office from a CD-ROM.

Method 2: Your Administrator Installed Office by Using the /J Switch

  1. Log off as the user and log on as an administrator.
  2. On the Start menu, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. In the Add/Remove Programs dialog box, click Office 2000, and then click Remove.
  5. Run Office Setup from an administrative installation by using the /j switch. For example, your command line might be:

    <path to administrative installation>\setup /jm

  6. When Setup is finished, log off as administrator and log on as the user.
  7. Start one of the Office programs.

MORE INFORMATION

For additional information about other scenarios where the Office programs may immediately quit when started, click the following article numbers to view the articles in the Microsoft Knowledge Base:

236592 Error messages starting Office 2000 program, or program immediately quits on Windows XP, Windows NT 4.0, or Windows 2000

236590 OFF2000: Error message starting Office program: 'Required registry information is missing...'


Modification Type:MinorLast Reviewed:1/28/2005
Keywords:kbprb KB257593