MSKey Keyboard Tool: Some Keys Do Not Appear to Be Depressed (257399)



The information in this article applies to:

  • Microsoft IntelliType Pro software

This article was previously published under Q257399

SYMPTOMS

When you use the MSKey Keyboard Tool that is installed with the Microsoft IntelliType Pro software, some keys may not appear to be depressed in the MSKey Keyboard Tool window.

CAUSE

This behavior can occur if you press multiple keys on the keyboard at the same time.

RESOLUTION

To resolve this issue, quit and then restart the MSKey Keyboard Tool.

To prevent this issue from occurring, type in the usual fashion. Make sure that you do not press multiple keys on the keyboard at the same time.

MORE INFORMATION

The MSKey Keyboard Tool is a utility that is installed with the Microsoft IntelliType Pro software version 1.0 or later. This utility allows you to confirm that when you press a key on the keyboard, an identical keystroke is detected by the computer.

To start and run the MSKey Keyboard Tool:

  1. Click Start, and then click Run.
  2. In the Open box, type mskey, and then click OK.
  3. Click the port to which the keyboard is attached.

    NOTE: If your keyboard is designed to be attached to both the PS/2 and the Universal Serial Bus (USB) ports, click PS/2 or the MSKey Keyboard Tool cannot detect your keyboard.
  4. Start typing to test your keyboard reaction.
Keyboards must discriminate between which keys are pressed. They do this by "scanning" the keys, which are electrically arranged into a set of rows and columns. Depressing multiple keys at the same time creates the most demanding scenario for the keyboard to uniquely detect keys.

Modification Type:MajorLast Reviewed:11/11/2002
Keywords:kbHardware kbprb KB257399