PRB: Installation of the MSDN Library DVD Version of Visual Studio Over the CD Version Causes Problems (257197)



The information in this article applies to:

  • Microsoft Visual Studio, Enterprise Edition 6.0

This article was previously published under Q257197

SYMPTOMS

When reinstalling Visual Studio Enterprise Edition from the MSDN Subscription DVD version over a previous standard three CD-ROM installation, the following error message may appear:
Various DLL's are unable to register themselves in the system registry
If you ignore the error message during installation you, and you later start any of the Visual Studio products, you receive the following error:
Memory could not be read

CAUSE

Because of corrupted installation paths and links, the system is confused about locations of files being either from the three-CD-ROM set or the single DVD disc.

RESOLUTION

To resolve this problem, manually uninstall and reinstall Visual Studio as described in the following Microsoft Knowledge Base article:

248697 HOWTO: Manually Uninstall Visual Studio with MSDN Library

MORE INFORMATION

Steps to Reproduce Behavior

Install the MSDN subscription DVD version of Visual Studio Enterprise Edition over an existing installation made with the Visual Studio Enterprise Edition three-CD set.

REFERENCES

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

240350 HOWTO: Manually Uninstall the MSDN Library

201420 HOWTO: Manually Uninstall and Update HTML Help

216109 HOWTO: Troubleshoot MSDN Library Run-Time/Install/Uninstall Problems



Modification Type:MajorLast Reviewed:10/2/2003
Keywords:kbprb kbsetup KB257197