SMS: Client-Side Remote Control Agent Does Not Listen on IP Addresses Assigned by RAS/Dial-Up Connections (256895)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q256895 SYMPTOMS
On dial-up computers, the Remote Control agent starts shortly after the computer is booted (about 30 seconds after the graphical user interface appears). Upon starting, the Remote Control agent tries to obtain an IP address on which to listen. If there are no valid IP addresses (which is usually the case before dialing), the agent listens on either 0.0.0.0 or an invalid, previous IP address.
CAUSE
The problem occurs when the computer uses Remote Access Services (RAS) to dial into a site and is assigned an IP address by the authenticating RAS server. The client-side Remote Control agent cannot "reset" itself to start using the newly provided IP address.
The source of the issue is the inability to obtain the new IP address and start listening on the new address instead of the old one.
WORKAROUND
To work around this behavior:
- Install the Stop Remote Control tool (Stoprc.exe) on the client computer. You can install the Stop Remote Control tool by
running the Microsoft BackOffice 4.5 Resource Kit Setup program, or by copying the required files to an appropriate location.
- After a dial-up connection is established and an IP address assigned, the client must run the Stop Remote Control tool to stop the Remote Control agent.
- Run the Stop Remote Control tool again to restart the Remote Control agent, which then picks up the newly assigned IP address.
- Let the Systems Management Server administrator know that the client computer can now be remote controlled.
NOTE: There is a difference when you run Stoprc.exe on a computer running Microsoft Windows 95/Microsoft Windows 98 and Microsoft Windows NT. The Windows 95/Windows 98 version of the tool stops and restarts Wuser32.exe. The interval between stopping and restarting varies from 2 to 30 minutes.
A Windows NT user must have local administrative rights to use this tool. These rights are required to stop and start the Remote Control agent.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server version 2.0.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbBug kbprb KB256895 |
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