PRB: HrGetBackupLogs() Must Not Be Called Before HrBackupClose() (256347)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 4.0 SP1
- Microsoft Exchange Server 4.0 SP2
- Microsoft Exchange Server 4.0 SP3
- Microsoft Exchange Server 4.0 SP4
- Microsoft Exchange Server 4.0 SP5
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.0 SP1
- Microsoft Exchange Server 5.0 SP2
- Microsoft Exchange Server 5.5 SP3
- Microsoft Exchange Server 5.5
- Microsoft Exchange Server 5.5 SP1
- Microsoft Exchange Server 5.5 SP2
This article was previously published under Q256347 SYMPTOMS- Information store does not start and hangs after restoring a backup using Tivoli client v1.1.1.
- If HrBackupGetBackupLogs() is called before HrBackupClose(), the call succeeds. However, the result of the backup is a database that cannot be restored consistently.
CAUSE
This behavior occurs because HrBackupGetBackupLogs() returns a list of log files that must be backed up. That list is generated only once per backup session, and the same list is returned from each subsequent call to HrBackupGetBackupLogs(). If HrBackupGetBackupLogs() is called before the database backup is complete, the list of log files is incomplete.
RESOLUTION
To resolve this behavior, the HrBackupGetBackupLogs() must be called after you call HrBackupClose() on the database.
To resolve this behavior with Tivoli client V1.1.1, upgrade to ver 1.1.1.01 of the client.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 3/11/2004 |
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Keywords: | kbMsg kbprb KB256347 |
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