SMS: SQL Account Problems Prevent Clients from Receiving Advertisements (256207)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0
  • Microsoft Systems Management Server 2.0 SP1

This article was previously published under Q256207

SYMPTOMS

When you create advertisements, the advertisements may never reach the client computers. When this problem occurs, the following lines are displayed in the Smsdbmon.log file:
Starting Manage Trigger thread...
CTriggerManager::RouteFiles - waiting on named pipe...

CAUSE

The SQL account used by the SMS_SQL_Monitor service is either corrupted or does not have the administrative permissions necessary to create triggers. Without the ability to create triggers, the process to send out Systems Management Server (SMS) advertisements does not start.

RESOLUTION

To resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

236325 How to Obtain the Latest Systems Management Server 2.0 Service Pack

STATUS

Microsoft has confirmed this to be a problem in Systems Management Server version 2.0 This problem was first corrected in Systems Management Server version 2.0 Service Pack 2..

MORE INFORMATION

A normal log file looks like the following example:
Starting Manage Trigger thread...
CTriggerManager::RouteFiles - waiting on named pipe...
Starting thread to monitor tracing...
CTriggerManager::RouteFiles - New connection made. Refreshing Registry values.

Modification Type:MinorLast Reviewed:6/14/2005
Keywords:kbBug kbenv kbfix kbsms200sp2fix KB256207