You receive a DirectX error message when you start a Microsoft game (256182)



The information in this article applies to:

  • Flight Simulator X Deluxe
  • Flight Simulator X Standard
  • Microsoft Age of Empires
  • Microsoft Age of Empires II: The Age of Kings 2.0
  • Microsoft Age of Empires II Expansion: The Conquerors
  • Microsoft Age of Empires II Gold Edition
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III Expansion: The War Chiefs
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: Gold Edition
  • Microsoft Age of Mythology: The Titans
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Dungeon Siege 1.0
  • Dungeon Siege: Legends of Aranna
  • Microsoft Dungeon Siege II
  • Microsoft Fable: The Lost Chapters PC
  • Microsoft Flight Simulator 2002
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Flight Simulator 2004 - Century of Flight
  • Microsoft Halo: Combat Evolved
  • Microsoft Links 2003
  • Microsoft MechWarrior 4: Mercenaries
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Rise of Legends
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft Zoo Tycoon
  • Microsoft Zoo Tycoon 2
  • Microsoft Zoo Tycoon: Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs Expansion Pack
  • Microsoft Zoo Tycoon: Marine Mania Expansion Pack
  • Microsoft Zoo Tycoon 2: African Adventure
  • Microsoft Zoo Tycoon 2: Dino Danger
  • Microsoft Zoo Tycoon 2: Endangered Species
  • Microsoft Zoo Tycoon 2: Marine Mania

This article was previously published under Q256182

SYMPTOMS

When you start one of the games that are listed in the "Applies to" section, you may receive an error message that states one of the following:
  • The game requires a later version of Microsoft DirectX.
  • The version of DirectX that is installed on the computer is incompatible with the game.
  • One of the DirectX files was not found.

CAUSE

This issue may occur if DirectX is not installed correctly on the computer.

RESOLUTION

Method 1: Reinstall DirectX from the game CD on a clean-booted computer

Step 1: Restart the computer by using a clean boot procedure

When you start Microsoft Windows, typically there are a number of programs that start automatically and run in the background that may interfere with the game. These programs may include antivirus and system utility programs. When you perform a clean boot, you prevent these programs from starting automatically. You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To restart your computer by using a clean boot procedure, follow these steps when you are using Windows XP.

Note You may experience a temporary loss of some services functionality when you follow these steps. Restoring the settings restores the functionality, but may cause the original error message or behavior to return.
  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective Startup.
  3. Under Selective Startup, click to clear the following check boxes:
    • Process SYSTEM.INI File
    • Process WIN.INI File
    • Load Startup Items
  4. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  5. Click OK, and then click Restart.
Click Play to view this streaming media demonstration:

For more information or to view steps for other operating systems, click the following article number to view the article in the Microsoft Knowledge Base:

331796 Games: How to perform a clean boot to prevent background programs from interfering with play

Step 2: Copy DirectX from the game CD and install DirectX

  1. Insert the game CD in your computer's CD drive or DVD drive.
  2. Press and hold down the SHIFT key when you insert the game CD to prevent the installation from starting automatically.
  3. On the desktop, double-click My Computer.
  4. Right-click the icon for your CD drive or DVD drive, and then click Open.
  5. Right-click the DirectX folder, and then click Copy.
  6. Close all the windows that are open on the desktop.
  7. Right-click an empty spot on the desktop, and then click Paste.
  8. Double-click the DirectX folder.
  9. Double-click the Dxsetup.exe file.
Follow directions that appear on your screen to install DirectX. Restart the computer when you are prompted to. If the issue continues to occur, go to the next method.

Method 2: Download and install the latest version of DirectX End-User Runtimes Web Installer

To do this, visit the following Microsoft Web site: Note You may receive the following error message during installation:
The software you are installing has not passed Windows Logo testing to verify its compatibility with this version of Windows. (Tell me why this testing is important.)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

822798 You cannot install some updates or programs


Modification Type:MajorLast Reviewed:10/10/2006
Keywords:kbsetup kbhowto kbArtTypeSHOWME kbenv kberrmsg kbimu kbprb msgame KB256182