XCLN: Appointments Created Using Collaboration Data Objects Off by One Hour (255879)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q255879

SYMPTOMS

If you use the Autoaccept script, which uses Collaboration Data Objects (CDO), to automatically book a conference room, a repeating appointment that falls across daylight saving time change periods is displayed with an appointment start time that is one hour later than the actual start time of the appointment for the first three weeks of March.

CAUSE

This issue can occur because CDO does not use the operating system TimeZone table to calculate daylight saving time adjustments. Instead, CDO uses its own internal table. This table incorrectly defines the end date for daylight saving time; as a result, appointments that you create during the overlap period are off by one hour.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the latest Exchange Server 5.5 Service Pack

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 4.

MORE INFORMATION

To manually install this fix, you need the Microsoft Register Server utility, Regsvr32.exe. The Regsvr32 utility is usually installed in your Windows\System32 folder. If you cannot locate the Regsvr32 utility on your computer, you can obtain it from the Microsoft Download Center. For additional information about where to obtain the Regsvr32.exe file, click the article number below to view the article in the Microsoft Knowledge Base:

161983 ACC: Regsv32a.exe Available in Download Center

After you obtain the Regsvr32 utility, you must perform the following steps to install this fix. The following command path

c:\winnt\system32

(which is used in the installation steps) may differ on your system, depending on the configuration of your installation of Microsoft Windows NT Server or Exchange Server.
  1. Copy the Regsvr32.exe file to your Windows\System32 folder.
  2. If the CDO client application is running on the same computer that Exchange Server is running on, stop all of the Exchange Server services.
  3. To unregister the current Cdo.dll file, at a command prompt, type the following:

    regsvr32 /u c:\winnt\system32\cdo.dll

    A message is displayed that indicates the success of this operation.
  4. Copy build 2651.91 of the Cdo.dll file to the C:\Winnt\System32 folder.
  5. To register the new Cdo.dll file, at a command prompt, type the following:

    regsvr32 c:\winnt\system32\cdo.dll

  6. If the CDO client application is running on the same computer that Exchange Server is running on, restart all of the Exchange Server services.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbExchange550preSP4fix kbExchange550sp4Fix kbfix kbQFE KB255879