OL2000: (CW) How to Re-Add a Missing Services to Your Outlook Profile (255638)
The information in this article applies to:
This article was previously published under Q255638 NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".
SYMPTOMS
When you try to add a service to your Outlook profile, the service may not appear in the list of available information services.
CAUSE
This behavior may occur if a service has been removed from the Add Service to Profile dialog box.
RESOLUTION
To resolve this behavior, you must rename all instances of the Mapisvc.inf file, and then enable Microsoft Windows Installer to repair the Mapisvc.inf files.
NOTE: The following steps recover deleted services if the services were installed by Outlook. The steps do not recover services that were installed by other programs or your operating system.
Rename the Mapisvc.inf Files
To rename the Mapisvc.inf files:
- Quit all programs.
- Click Start, point to Find, and then click Files or Folders.
- In the Named box, type mapisvc.inf.
- Click to select the Include subfolders check box.
- In the Look in list, click My Computer, and then click Find Now.
- In the Name list, right-click the Mapisvc.inf file, and then click Rename. Rename the file to Mapisvc.old.
NOTE You must rename each of the Mapisvc.inf files in the list. - On the File menu, click Close.
Repair the Mapisvc.inf Files
After you rename the Mapisvc.inf files, use the following steps to repair the Mapisvc.inf files:
- Start Outlook, and make sure that you have your installation CD-ROM available.
- On the Tools menu, click Services.
The Microsoft Windows Installer starts and automatically copies a new version of the Mapisvc.inf file to your hard drive. The Windows Installer may prompt you for your installation CD-ROM. - After the installer is finished, click Add in the Services dialog box. The service that you previously removed now appears in Available information services list.
NOTE: If the file is renamed and the Windows Installer does not re-install it properly, rename the file, run Office Repair and try to open the file again as per the steps listed earlier in this "Resolution" section.
Modification Type: | Minor | Last Reviewed: | 10/15/2003 |
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Keywords: | kbprb KB255638 |
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