SQL Server Backup to Remote Drive Does Not Work, Generates 'Error 18204 Access is Denied' Message (255235)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0

This article was previously published under Q255235

SYMPTOMS

When you attempt to back up a server running Microsoft SQL Server to a remote network share, the backup attempt may not succeed and the following error message may appear:
18204 Access is denied

CAUSE

This behavior can occur when the MSSQLSERVER account does not have the correct access permissions to the folder where the backup file is to be created.

RESOLUTION

To resolve this behavior, make sure that the MSSQLSERVER account has been granted the Access this computer from the network user right on the remote computer, and that it has Full Control permissions to the folder where the backup file is to be created. If the backup file already exists on the remote share, make sure the MSSQLSERVER account has Full Control permissions to the existing file.

MORE INFORMATION

You can check your MSSQLSERVER account permissions by logging on to the Microsoft Windows NT Server 4.0-based computer where SQL Server resides, using the MSSQLSERVER account. Map to the remote drive, and then delete, rename, or create a file in the destination folder where the dump file is to be stored. If that does not work, then the account does not have the proper permissions.

Modification Type:MajorLast Reviewed:1/25/2005
Keywords:kbprb KB255235