POP3 Connector for Exchange Does Not Deliver Mail When IMS Requires Authentication (255125)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q255125

SYMPTOMS

The connector for Post Office Protocol 3 (POP3) mailboxes retrieves e-mail messages from POP3 mailboxes, but may not deliver them to the correct recipients. When this occurs, no error messages are reported in the event logs.

CAUSE

This behavior can occur if the Internet Mail service (IMS) for Microsoft Exchange is configured to require authentication and/or encryption for hosts that connect to the Simple Mail Transport Protocol (SMTP) interface.

RESOLUTION

To resolve this issue, use either of the following methods.

Method 1

Disable authentication and encryption on IMS:
  1. Start the Microsoft Exchange Server Administrator tool.
  2. Click Connections, and then double-click Internet Mail Service.
  3. On the Connections tab, click From any hosts (secure or non-secure) in the Accept Connections box, and then click OK.
  4. Stop and restart the Microsoft Exchange Internet Mail service by using the Services tool in Control Panel to apply the changes.
  5. Stopping the Internet Mail service also stops the POP3 connector. Manually restart the POP3 connector by using the Services tool in Control Panel.

Method 2

If you need to use authentication, use the Specify by host setting to specify the Small Business Server-based computer's IP address, and specify the Accept connection from this host setting:
  1. Start the Microsoft Exchange Server Administrator tool.
  2. Click Connections, and then double-click Internet Mail Service.
  3. On the Connections tab, click Specify by host.
  4. Click Add, and then type the IP address of your internal network.
  5. In the Subnet Mask box, type 255.255.255.255.
  6. Click Accept connection from this host, and then click OK.
  7. Stop and restart the Microsoft Exchange Internet Mail service by using the Services tool in Control Panel to apply the changes.
  8. Stopping the Internet Mail service also stops the POP3 connector. Manually restart the POP3 connector by using the Services tool in Control Panel.

MORE INFORMATION

The POP3 connector connects to the IMS SMTP interface to route incoming POP3 e-mail messages. If IMS is configured to require authentication and/or encryption, the POP3 connector cannot route e-mail messages successfully.

You can enable the Maximum Logging for SMTP Client Transactions option under the Delivery Service category on the POP3 Connector Diagnostic Logging tab. Event ID 4032 for the POP3 connector then displays the results of the SMTP transaction. Event ID 4022 displays the SMTP transaction transcript:
Event ID: 4032
Source: POP3 Connector
Type: Information
Category: Delivery

A recipient has been processed. Recipient information:
NDR Status Code: 502
Error Code: 00000000
SMTP Reply: 505 Authentication required
SMTP Name: user@domain.com
SMTP Host: SBSSERVER


If the mail address of the sender is an invalid SMTP mail address, the SMTP transaction transcript will indicate an error 553 malformed address followed by the invalid SMTP mail address. Examples of invalid mail addresses include, but are not limited to: "username", "user@domain", and "First Name, Last Name".

A valid mail address appears as "user@domain.com".

NDR Status Code:502
Error Code:00000000 
SMTP Reply:553 malformed address: <invalid mail address> 
SMTP Name:<user>@<sbsserver>.com 
SMTP Host:SBSSERVER  

NDR Status Code:600
Error Code:000006c0 
SMTP Reply:553 malformed address: <invalid mail address> 
SMTP Name:<user>@<sbsserver>.com 
SMTP Host:SBSSERVER
					

An example of a successful SMTP transaction transcript is shown below:

NDR Status Code:1
Error Code:00000000
SMTP Reply:
SMTP Name:<user>@<sbsserver>.com
SMTP Host:SBSSERVER
					


Modification Type:MajorLast Reviewed:8/6/2002
Keywords:kbenv kbprb KB255125