You receive an "Internal Error 2932: Please contact product support for assistance" error message when you apply the Office 2000 SR-1 Update on Windows 2000 (254869)



The information in this article applies to:

  • Microsoft Office 2000 (Setup) Service Release 1 (SR-1)

This article was previously published under Q254869

SYMPTOMS

When you run the Microsoft Office 2000 Service Release 1 (SR-1) Update, you may receive the following error message:
Internal Error 2932: Please contact product support for assistance.
If you view the verbose log file text for the update, you see text similar to the following:
MSI (s) (A4:F8): Executing op: SetTargetFolder(Folder=E:\WINNT\Fonts\)
MSI (s) (A4:F8): Executing op: SetSourceFolder(Folder=F:\Windows\Fonts\)
MSI (s) (A4:F8): Executing op: FileCopy(SourceName=TAHOMA.TTF,DestName=TAHOMA.TTF,Attributes=8192,FileSize
=257636,Version=2.60.0.0,,InstallMode=58982400,PerTick=32768,IsCompressed=0
,,VerifyMedia=1,,VitalPatches=15,PatchHeaders=Binary00
Internal Error 2932: Please contact product support for assistance.
Action ended 8:14:53: InstallExecute. Return value 3.
				

CAUSE

This problem occurs if all of the following are true:
  • You are using Microsoft Windows 2000.
  • You are logged on as a power user.
  • Windows 2000 is installed on an NTFS drive.
  • You installed Office 2000 while you were logged on as a power user.
  • You attempted to install the Office 2000 SR-1 Update.

RESOLUTION

To resolve this problem, do one of the following:
  • Run Setup by using the Office 2000 SR-1 full-package product compact disc.

    -or-
  • Run Setup from a network installation of Office 2000 SR-1.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

If you want to prevent users from applying a Windows Installer patch, you can turn on (enable) the Disable Patching system policy by using the group policy editor. Doing this sets the DisablePatch DWORD value to 1 for the following key in the registry:

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer

If this policy is in effect, instead of displaying the 2932 error message, the SR-1 update displays the following message just after you start the update process:
Microsoft Office 2000 SR-1 Update did not complete successfully. For assistance, contact Microsoft Technical Support.

See the log file: Office 2000 SR-1 Setup(####).txt

where #### in the log file name is a number like 0001.

This log file is located in your \Temp\SR1Patch folder along with another log file with a name similar to:

Office 2000 SR-1 Setup(####)_MsiExec.txt

If you open the Office 2000 SR-1 Setup(####)_MsiExec.txt log file, you see text similar to the following:

This installation is forbidden by system policy. Contact your system administrator.
E:\Winnt\Installer\abdie.msi

NOTE: If you apply the Disable Patching system policy, all Windows Installer patching will be turned off (disabled), not just the SR-1 update.

REFERENCES

For additional information about using Group Policies to manage Windows Installer Local Policies, click the article number below to view the article in the Microsoft Knowledge Base:

227181 How to Manage Windows Installer Local Policies


Modification Type:MinorLast Reviewed:1/28/2005
Keywords:kbtshoot kbstartprogram kbsetup kberrmsg kbprb KB254869