Some Network and Dial-Up Connections Icons May Be Missing (254631)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Datacenter Server
This article was previously published under Q254631 SYMPTOMS
After you click Start, point to Settings, and then double-click Network and Dial-up Connections, or Right-Click My Network Places on the desktop and
select properties, you may experience one or more of the following symptoms:
CAUSE
This behavior can occur because of one or more of the following reasons:
- The Plug and Play service is not running, causing the Local Area Connection icon to not be displayed.
- The Remote Procedure Call (RPC) service is not running, causing the Make New Connection icon to not be displayed.
- You used the Dcomcnfg.exe tool to change DCOM default settings, causing the error message listed earlier in this article to be displayed.
- One of the following network dlls is not properly registered.
- Netcfgx.dll
- Netman.dll
- Netshell.dll
- The Network Connections service is disabled or is not started, causing the Local Area Connection icon to not be displayed.
RESOLUTION
To resolve this behavior, use the appropriate method:
Verify That the Device Resources Are Correct
To resolve this behavior:
- Obtain the network adapter configuration utility from the manufacturer of the network adapter. Typically, you must boot the computer from an MS-DOS or Windows 95/98 Startup disk to run these utilities.
- If the network adapter uses jumpers for its settings, verify that the settings do not conflict with another device and manually change them to a resource setting that is not currently in use.
NOTE: You may need to remove all devices except the NIC and add them back one at a time to determine which device the network adapter conflicts with.
Start the Plug and Play Service
To resolve this behavior:
- Click Start, point to Programs, point to Administrative Tools, and then click Computer Management.
- Double-click Services and Applications, click Services, and then double-click Plug and Play.
- In the Startup type dialog box, click Automatic, click OK, and then restart your computer.
NOTE: If the Local Area Connection icon is still missing, press F5 several times to refresh the screen. Also, you may try restarting your computer in Safe Mode with Networking.
Start the RPC Service
To resolve this behavior:
- Click Start, point to Programs, point to Administrative Tools, and then click Computer Management.
- Double-click Services and Applications, click Services, and then double-click Remote Procedure Call (RPC).
- In the Startup type dialog box, click Automatic, click OK, and then restart your computer.
NOTE: If the RPC Service is disabled, you may need to use the Recovery Console.
For additional information about starting and using Recovery Console, click the article number below
to view the article in the Microsoft Knowledge Base:
229716 Description of the Windows 2000 Recovery Console
- In Recovery Console, run Enable RPCSS Service_Auto_Start, and then restart your computer.
NOTE: If the Make New Connection icon is still missing, press F5 several times to refresh the screen. Also, you may try restarting your computer in Safe Mode with Networking.
Reset Default DCOM Permissions
To work around this problem:
- Click Start, click Run, type dcomcnfg, and then click OK.
- On the Default Properties tab, click any setting other than Anonymous in the Default Impersonation Level box. The default setting is Identify.
Register the Following Dlls- Click Start, click Run, and then type cmd.exe on the Open line.
- Type the following lines, and then press ENTER after you type each line:
regsvr32 netshell.dll
regsvr32 netcfgx.dll
regsvr32 netman.dll
- Restart the computer.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
This problem also occurs if the Allow service to interact with desktop check box is cleared on the Log On tab in the properties of the Network Connections service.
Modification Type: | Major | Last Reviewed: | 12/3/2003 |
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Keywords: | kberrmsg kbprb kbRPC kbui KB254631 |
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