System Event ID 36876 When Using LDAP SSL Query of the Active Directory (254610)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
This article was previously published under Q254610 SYMPTOMS
When you attempt to perform Active Directory LDAP queries using a secure connection (SSL), you may receive the following error message:
There are no entries in the directory service that match your search criteria.
Also, the following error message may be added to the System Event Log:
Type: Error
Event ID: 36876
Category: None
The certificate received from the remote server has not validated correctly. The error code is 0x80090322.
The SSL connection has failed. The attached data contains the server certificate.
CAUSE
This issue can occur if the Active Directory Account Properties are missing or incorrectly configured.
RESOLUTION
To resolve this issue, view and correct the Active Directory properties:
- Click Start, point to Programs, point to Accessories, and then click Address Book.
- On the Tools menu, click Accounts.
- Click Active Directory, and then click Properties.
- In the Server name box, type the fully qualified name for the computer that contains the Active Directory.
For example, type the name using the following syntax
where computername is the name of your computer, domain is the name of your domain, and com is the extenstion of your domain.
If the server requires you to log on, click to select the This server requires me to log on check box, and then type the account name and password in the Account name and Password boxes. - On the Advanced tab, click the This server requires a secure connection (SSL) check box to enable secure LDAP queries.
NOTE: SSL communications use port 636. - In the Search base box, type the domain name and extension using the following syntax:
- Click OK to apply the changes.
Modification Type: | Major | Last Reviewed: | 11/20/2003 |
---|
Keywords: | kbenv kberrmsg kbnetwork kbprb KB254610 |
---|
|